Sonoff temperature sensor disconnection issues

I have two Sonoff temperature sensors – one air temperature, used to control central hearing, and one probe attached to a hot water cylinder to control its heating. They have proved sadly unreliable in that they will work fine for a while and then disconnect from the WiFi network for no apparent reason, so become unavailable to the controlling program (Home Assistant with the Sonoff eWeLink integration).

Sometimes just powering off and on again is sufficient to reinstate the connection, sometimes I have to do a complete reset and reconnect. Either is unacceptable as the installation is not near where I live.

Is there anything I can do to make them reliable, or do I need to replace them with a different brand?

Oddly, a cheap Chinese temperature and humidity sensor I bought recently (connected via SmartLife) has proven more reliable!

I have the same problem with a SONOFF B02-F-A60 vintage bulb. It worked fine for several weeks. Trouble might have started after firmware update to version 1.3.5.

When Android eWelink App displays the device as disconnected I can still ping it. So it is still connected to the WiFi network, but communication between device and WiFi repeater/app seems partly broken.

eWeLink versions used are 4.32.0 and 4.34.1.

I have 2 TH16 working fine for 2 years. A couple of days ago my Home assistant routines started reporting the TH16s were ‘not running’. Both devices show in Ewe link app and correctly report the measured temperature but when you try to switch on the attached loads they both report 'Failed. Network connection error. I’ve checked connectivity to [] and [] and ping and tracert and they both seem fine. Also brings up the ‘Welcome to OpenResty!’ webpage okay. Any advice?


1 Like

I’m getting the same, ewelink app reports device off line (temp/Humidity Sensor) but when i log in its back online, and my logs show that the device was offline for less then a minute!

Mine are also TH16s and I also have the problem that the app cannot send commands, though oddly Home Assistant still can.

They seem to have messed up the eWeLink app because I am also unable to add new devices at the moment – the app says the phone İs not connected to WiFi even though it is (I reported this separately).

Not only the eWeLink App reports the B02-F disconnected but also the WiFi router does so while I can still ping it.

Todays news: I can ping the B02. eWeLink app V4.32.0 reports the B02 disconnected.
V4.32.1 reports it connected. 10 seconds approx. after trying to switch state of the B02 message “Sorrry, no answer. Please try it again” is displayed. Power off/on brings the B02 back to life.
What’s next?

yep, having same issue here with my TH-elite… i noticed that it happens more often when the wifi channel changes…

@robsonfj @mrgagreer @k543fr-ewe @andrew.w.symons @roy.westacott
Hi there, thank you for reporting this issue. We apologize for any inconvenience you may have faced. To better assist you, could you please provide us with more details about the affected devices, including:

  1. Device ID
  2. Router model
  3. Is your home network set up using multi-router Mesh networking?

This information will help us investigate the problem more effectively. Thank you for your cooperation.

DeviceID: 1001da31d5

I have a unifi router UDM-Pro and 3 unifi access points U6-lite

AVM Fritz!Box 7490, AVM Repeater 1200, Mesh
100137d469 located very close to and connected to Fritz!Box 7490
10014944d4 located close to and connected to Repeater 1200

I can confirm robsonfj’s wifi channel change issue. This showed up soon after installation of the B02. Locked channel for a (bad) workaround. After that had no problems from mid of May to mid of July.

Another detail: After eWeLink shows the B02-F disconnected it took about 3 seconds for the first response to a ping.

Made some progress! As Andrew stated Ewelink (latest ver) reported no network connection despite that being untrue, the devices lan connection LEDs were on and they were still reporting temps correctly but unable to switch or access the device settings menu. Unlike Andrew Home assistant didn’t work at all being unable to recognise the device names.

I removed the devices from the Google home, cleared all Ewelink caches , removed and reinstalled Ewelink. The app is now working correctly but on relinking the home assistant devices are showing linked but offline. Assistant reports it couldn’t reach Ewelink.

My router is a Standard issue UK ISP supplied device , the device IDs are 1000fde8d8 & 1000becac4.

WLan is not a mesh, just a dual band wifi router with separate 5 and 2.4 wlans.


Hi there, I can see from the server that your device is currently operating normally. Are you still experiencing frequent offline issues with this device?

Hi there, thank you for your update. It’s great to hear that you’ve made some progress in troubleshooting the issues you were facing. Clearing the cache can indeed be effective in resolving discrepancies in app information, as it refreshes the data.

Regarding the information you provided about uninstalling and reinstalling the app, then reconnecting to Home Assistant resulting in the devices showing as linked but offline, could you please specify where exactly these devices are displaying as offline? Is it within the eWeLink Smart Home Add-On’s dashboard?

Do you mean me?

I have two devices, a THR316D (with screen) using an air temperature sensor, and a THR316 (no screen) with a temperature probe. At the time of posting, the THR316D is working correctly, but the THR316 is showing the temperature as “unknown” – which I think means it thinks the probe is disconnected (though it, the probe, and the leads are all new).

By “working correctly”, I mean I am getting sensor readings for temperature and humidity in Home Assistant. They both suffer from the bug that I cannot operate the switch from the eWeLink phone app; they work from HA but I do not use the switches anyway.

In both cases I have installed additional backup sensors alongside the SONOFF sensors and have so far found them to be more reliable. That was abut two weeks ago. At the same time I reset both SONOFF sensors by turning the power off and on and I updated the firmware to the latest version. They both worked at first but the THR316 failed after a couple of days (so I am using the new backup sensor) and the THR316D is still working.

The THR316 has one backup (also WiFi) and the THR316D has two (one Wifi, one Zigbee). All the backups are still working OK. The backup sensors are in similar areas to the SONOFF sensors, spaced by about 30cm to avoid interference from each other, so have the same environment and signal strength.

It seems a little more stable for now… It is over a week now since the the last offline issue occured… i have in the wifi logs the last time it disconnected… Jul 30, 2023 10:31 UTC -3

Again, are you replying to me? If so, then you are right that the WiFi is still connected to both. However, one of the TWO devices has been showing ‘unknown’ most of the time. This is probably a sensor issue rather than WiFi, but still too unreliable to use. Interestingly, it seems to work briefly each day when the temperature is at its lowest. It is connected to a hot water cylinder and the heating is turned off at night.

The faulty SONOFF sensor…

The other sensor, which is working correctly.

Hi there,
I understand that you are encountering issues with two of your devices: a THR316D and a THR316. The THR316D is working as expected, providing temperature and humidity readings in Home Assistant. However, the THR316 is displaying the temperature as “unknown”, both devices experience a bug where the switch cannot be controlled from the eWeLink phone app, although they can be operated through Home Assistant.

Both devices initially responded after being reset and having their firmware updated. However, the THR316 failed after a few days of operation, while the THR316D continues to function properly.

And the WiFi connection of both devices appears stable, the THR316 has been displaying the “unknown” temperature most of the time. This issue seems more related to the sensor itself rather than WiFi connectivity.

To better assist you, could you please provide the device IDs of both devices? We kindly request that you submit a support ticket through the eWeLink app, including this information. Our support team will prioritize addressing your concern promptly.

1 Like

Hi Stephen

thanks for your reply, the ewelink app now works perfectly. The issue now is a failure to relink it with google home assistant. It completes the process of adding the devices to my home but they then show as offline devices in the google home app. I don’t think it’s anything to do with my phone, my partner also has a pixel 2 (also android 11) and the issue is exactly the same on that phone.