Sonoff mini R1 & R2 & Smart Socket(S236TPF-DE)


Since december i’m facing with some issues in my ewelink devices that are working for about ⅔ years.
Most of the times when i try to switch on or off the devices are unresponsive through the ewelink app or voice command (alexa). After a moment they came back online.
Sometimes one response and others don’t.

Has anyone had this problem and solved it?

I’ve done the following operations to try to solve it:

I disable the ewelink skill on alexa,
Removed the devices on alexa APP
Removed the devices on ewelink app
Sign Out in both apps & cleared the cache on both
Uninstalled alexa app and ewelink
Paired the devices again

Also changed the router with the ISP provider and setup the 2.4ghz network and did all the things up again.

Today i setup in the router Fixed IP through mac address in all devices

I don’t know what else I can do…maybe if i downgrade the app version? downgrade Firmware? what can i do ?

The firmware off the mini’s it’s 3.7.6

Thank you for your time and willingness to help

Looks like a WLAN problem to me. How about other devices (PC, phone, etc.)? Do they maintain a stable link?
I understand that you set fixed IP address for all Sonoff devices, starting from, right?
Please, write more about your MINIs, as there are several makes.

Yes, the other devices maintain a stable link.
I even have 2 other smart home devices from another brand that work without any problems.

Yes, i fixed the ip startung on

Mines minis are the r1 and r2 stock version only changed it’s updating the new firmware when ewelink deploy new versions.

I though that was a wlan problem and i changed the internet routet to a new one…but the problem remains

I am guessing that you are using a password for WLAN. Is it long and does it contain special characters and/or spaces? Your router is dual-band, yes? Are the 5 and 2.4 GHz network names the same or different?
Disable network security for a while and see how the Sonoff devices behave.

Yes, I have a password and it’s only numbers or letters.
Double band and different names.
This has been working for almost 3 years

Thanks, I’ll try the security option.

If i buy a sonoff gateway and sync all devices it ll solve the connection problem?
The sync with the router will be from gateway right?

The gateway is for Zigbee devices and needs wifi too.

I suspect there’s something wrong with the wi-fi channel. Do you feel comfortable making a switch for your 2.4GHz wifi’s working channel? I had similar glitches with my other wi-fi devices, and such experimental moves worked.

Btw, if you need professional help, I would highly recommend you raise a support ticket, the guide is now part of the placeholder when you create a post here. :see_no_evil:

Which gateway are you referring to? With your current devices, there is no need for a gateway.
Try setting the WiFi channel in your router to 1 or 6 and see what the results of this change are. @port4u’s guesses may turn out to be correct. Especially if you have multiple wireless networks running in your location.

1 Like

Yes, i feel confortable making the switch.
If memory serves i think the 2.ghz wireless network is on channel 10.
I’ll change it to that values that @jam3 said.

Thank you both i’ll give you feedback after testing

1 Like

Tried 1 and 6 but the problem still remains

Let’s move on. The problems started in December. Did you make any changes to your network then? A new router? A change of your router’s location? A WiFi repeater added? Why did you decide to assign fixed IP addresses? Did you ensure that the assigned addresses did not conflict?
What router are you using? Does it have some sort of LAN (WLAN) survey where you can see the WiFi clients and the quality of the signal reaching them?

Until the problems started, I hadn’t made any changes to the network. They had been working for more than 2 years straight.
Now, in January, after trying a thousand and one things to resolve the problem and without success, I asked Vodafone to change my router for a new one.
Routers location is the same for both (old and new)
I set the IP because I had seen on forums that some users had had similar problems and that by setting the IP on a 150+ network the problem had been solved.
I’m using now the mi wi-fi ranger extender prob(2.4ghz) instead of dual network from vodafone router but i have the same problem.
Signal good strenght… 3 devices are like 1meter from the router.

Could be one broken or in bad shapr and make this conflits on network?

Router model - Huawei OptiXstar HG8247X6-8N