I have had my iHost delivered today and I am struggling to get a TF card accepted. I have a sandisk ultra Class 10 and the formatting keeps failing. It works fine on my PV and Mac but fails on iHost. It’s a 128gb, any suggestions please

I had the same problem with a Kingston 64GB class 10SD card, and not just one, so I tried a Sandisk ultra class 10 SD card with 32GB with success.

What is the recommended size TF card for the iHost?

Sonoff recommendation:

Hi, I tried a 128gb Sandisk Ultra and that would not work. I’ve now got a 128gb Sandisk Elite and that works ok. Both were class 10

Thank you for your information, but do you know the speed of this two cards?

The elite is 200mb/s read and 90mb/s write and the according to google ultra was 120mb/s

I can’t get a Micro SD card working either. Suddenly the 32GB Kingston CANVAS Select Plus I got from Sonoff for the iHost I received to test doesn’t get recognized anymore after issues with error messages like “Docker process error”. The card is still recognized by Windows 10 on my laptop, but ofcourse because of the special formatting I can’t see the contents.

I tried a Samsung EVO Plus 64GB Micro SD card (my favorite and most stable brand of Micro SD cards), but the formatting times out all the time according to the Mozilla Firefox developer console. This cause the “Continue” button on the formatting dialog to become enabled again. The result is a card still not formatted.

I also tried a Samsung EVO 64GB USB mass storage and although the iHost recognizes it, during formatting it is nagging me about the absense of a TF card.

I filed a feedback ticket from within the iHost UI.

The Micro SD card support should be a lot better than this. Also a USB mass storage should be good alternative without hassle (why else would you put a USB port on the iHost?).

Untill the Micro SD card formatting issue has been solved I can’t use the iHost now… And I already wasn’t very satiesfied with the iHost. For now Home Assistant seems to be just way more mature stable and a better choice for local automation.

Actually using a FT card I think is a bad idea and something I was going to mention in the future. It is recommended for HA on a Pi not to use a TF card, the constant read/write burns out the cards. Everyone I know running HA on a Pi uses a SSD.

Although I believe a harddisk / SSD is better, a Micro SD card is a bit more convenient to install.
I believe the iHost should have come with onboard memory of 128GB or greater.

In the meanwhile I got my Micro SD card running again. I decided to format my Samsung EVO Plus 64GB card with the SD format tool on my Windows 10 laptop to get that card back to normal again. Then I suddenly thought maybe it will help me forward with the Kingston CANVAS Select Plus 32GB card too. And it indeed did the trick. The card got recogbnized again by the iHost, I was able to format it within the iHost UI, I was able to configure the Docker containers for eWeLink CUBE and Node RED and it now seems to run again. But still this part of the iHost needs improvement as it is unreliable now.

In the meantime I have also stopped using the iHost regarding the setup and installation of add-ons.
First I used a Samsung 128GB Pro Plus which was immediately recognised, formatted and installed the Ewelink add-on along with Nodered, then I thought to install another add-on and it kept installing for hours and hours.
After reading the problems with sdcards, I took one with a smaller capacity, Sandisk Ultra 32Gb, as recommended, formatted it, but it keeps asking to format.
Then a full hard reset of the iHost and put the 128Gb card back in, now it is no longer possible to use it while it worked first.
So it works in a loop, first format card–> cards is already formatted–>when installing add-on–>format card first…
I give up…

1 Like

Yes, it is frustrating. I have two iHosts on my desk and finally I have (different) tf cards that are stable. This issue is appearently known and will be addressed in the upcoming update. As to that specific issue with the 128GB card: Format it first in a different device. Then reinsert it and let iHost format it to its needs.

1 Like

Mine seems stable although I haven’t started with addons test until more devices are supported. Mine would not work with older cards I had used before but with a new high speed card it seems fine.

1 Like

That’s exactly what I did, first formatted in Windows, then placed in the iHost, which then asks to format it and reports ready.
(The Sandisk Ultra 32Gb is not recognized at all, as is a 16Gb class10 card from the brand Kangourou).
Installing Ewelink smart home took 1 minute for the first time.
Now, after a general reset, it’s been installing for an hour.
Then forced a reboot where the iHost keeps shutting down until I just unplug the power cable.
At the next start-up, it has installed for a while and is now ready to start Ewelink smart Home… pffff :grimacing:
In the meantime I have already gained 64 gray hairs :face_with_raised_eyebrow:

Yes Matthew, I think I should let it go for a while, but it depends on my drive to get everything right :slightly_smiling_face:
However, if the iHost hardware and software is not optimized, it makes no sense to spend any further time on it :roll_eyes:.
So I’m going to try :face_with_hand_over_mouth:

The old ordinary KIOXIA EXCERIA microSDHC 32GB SD card solved everything for me. She caught on the first try. Everything works fast and reliably, I have not experienced any problems.

EXCERIA microSD Memory Card

1 Like

Is there a timeline on it? I’ve tried 3 microsd cards and I’m not spending another cent until I know it’s a usable card. 2 of them are mentioned as working in this thread.

It looks like I’m among those lucky ones that have no problems with SD cards that match general requirements for iHost. Any that goes to the slot is accepted and can be formatted. It was 5 or 6 of them. As for the time being, I’m using 64GB PNY Elite microSD Class 10, UHS-I, U1.

Same here. SanDisk Ultra 128GB didn’t work. SanDisk Extreme 128GB works.

Good morning.
In mine, as soon as he reads it or not. Packages appear in docker as not installed. I reinstall them and they appear without having lost the configuration.
Still, as long as they don’t fix the card issue, it’s still unreliable.
Right now I don’t have time, but if the usb port is used for storage, maybe try a pendrive or an external ssd or hdd.

1 Like