iHost doesn't respond well - example Reboot

Hi. I have two iHosts (one is for a friend and one for me for testing purposes). So far I am rather disappointed. I have several issues. I will split them up in different topics (or participate in existing threads). But generally I must say that both iHosts often just don’t react or proceed with a task, without me knowing why. One simple example ist rebooting. I have so far not managed to reboot the iHost. It does go into shutdown mode. The red light keeps running. But I then need to disconnect it from power in order to make it reboot. I have a feeling, it might be related to v1.5.3. But I wouldn’t know how to verify that.

1 Like

Is some operation running in the background (download, installation of an add-on)? It cannot be known, no graphical representation or indication of the current status. I had a similar problem, solved with a different (older) SD card.
After replacing the card, iHost started to behave “normally”

Thanks! Actually I have two iHosts at the moment and both share a range of problems. Yes, in the first few cases the iHost is in the process of installing a docker, but obviously stuck there for some reason. Rebooting is the only way of triggering a continuation. But meanwhile I have also tested it without any (visibly) active processes. So far I have not been able once to do a soft reboot on any of the iHosts,
Thanks for the tip with the card. I read about such issues in another thread and just ordered a 128GB Sandisk Elite. Maybe the SDcard does contribute to the problems.

I only put 32GB, I also tested a larger capacity and it didn’t turn out well in iHost.
Also, interrupting a “stuck” installation or download did not go well. After one interruption, the iHost system installed the add-on for me, but in a non-standard way, which caused major problems.
I solved the slowdown and long installation times with a card that has to work like this on the first try, otherwise you won’t get out of those problems.

1 Like

The original non-functional SD card (Kingston) was even directly recommended as an accessory to the iHost upon purchase.

It seems, you are right. I completely resetted both iHosts. Twice, actually. Then I switched the larger microSD for an older one, but also class 10. The second iHost got a new 128GB SanDisk Ultra. I started installation processes simultaniously. The iHost with the larger card is not performing well. The one with the older, but smaller micro SD is faster when it comes to installing and running add-ons. The one with 128GB is barely usable.

Yes, I also reset iHost several times and didn’t want to accept the fact that the problem could be hiding in the new SD card.

1 Like

hi, how do you confirm that soft reboot is not successful?

Hi Teki. Because it simply doesn’t reboot. Light stays red, the reboot prompt on the screen doesn’t change. And it stays like that overnight, until I pull the power plug next morning. After the tip from @Rossi14 I use a different sd card (older, but smaller) and a reboot works there.
I currently have two iHosts running parallel. The one with the older 32GB sd card works ok. The one with the new 128GB is pretty much unusable. Processes are stuck.

Thank you for the feedback, we’ve noticed that there may be some problems when you insert some TF cards, we’re doing some tests trying to find a solution.

For the one you cannot use normally, try following steps to see if they help:

  1. remove the TF card and reboot iHost, then insert the TF card.
  2. format the TF card on a PC in step 1
  3. use another web browser (or open in a incognito window)
  4. change a TF card, which you’ve already done.

If you’ve tried everything without help, please wait for a firmware update. We appreciate your patience and understanding in this matter. We take feedback from our users seriously as it helps us improve the quality of our products and services.

1 Like

Thanks. I am in the fortunate situation where I have two iHost device, which enables me to do some structured testing. And yes, the tf card does make all the difference. I have already tried all recommended points and can say that an iHost device will have problems under 1.5.3 with a SanDisk 128GB Ultra (UHS I), which works flawlessly in other devices.
For me the cause is reproducable, so I will close the thread. Thanks!

Since replacing the SD card with an old one with a smaller capacity, everything is fine. The device also runs in optimal temperatures from 42-50C. Nothing stutters, nothing lags, everything runs smoothly. I am slowly starting the scenes that I am blessed with in eWelink :slight_smile:

1 Like

Thank you very much for your time and kindness. We are aware that some TF cards may cause Docker Engine (the one powering AddOn feature of iHost) to malfunction. We are working on it and will release a new firmware version next week, hopefully solving most issues related to TF card.


Great. We really need that update.
I had all the problems described above…
I lost count on the times I’ve reboted iHost, lost count on how many times reset it, and lost count on how many different TF Cards tested… Now the best TF Card to use with iHost is an old 32Gb instead of the new one with 128Gb.
I really trust onthe best Brand in the world: Sonoff and all the team :blush::heart: