Firmware 1.5.5 for Sonoff iHost is available to install

I just discovered firmware 1.5.5 for the Sonoff iHost is ready to install:

Provided changelog at the webinterface of the iHost:


  • Fixed the known issue of TF card formatting failure.

  • Streamlined the TF card formatting procedure.

  • Improved with the ability to automatically detect and repair disk issues.

  • Enhanced the recovery mechanism for Docker after an unexpected power failure or system crash.

I didn’t have any issues with the SD card for quite a while now. I use the Kingstond 32GB card that came with my iHost. I hope it will keep on running and I also hope the firmware brings improvements to others.

1 Like

Be cautious installing the 1.5.5 firmware.

After installation it demanding a format of my existing SD card (a 64GB Transcend). The format failed, all subsequent attempts to format failed. Everything on the card is now inaccessible and I can’t roll back to previous firmware.

I recommend you skip this firmware if your iHost is working currently, and wait until there is another update - and then wait again so you aren’t the unwilling victim of another problem.


Luckily I didn’t have such issues after this update, but it is good to warn for such issues so that people can take note of their current settings.

Sorry for the inconvenience, feedback received, it’s wired that some users upgraded smoothly without issue as we tested process goes, and we are working on to locate and sort out the possible reasons caused this urgently, get back to you once we have some clue.

1 Like

Same topic here Card iHost

Sorry for the issue, dev-team are working on tracing it, will roll the thread in upon topic.

The same thing happened with my update. After the update to 1.5.5, the TF card is no longer displayed :frowning:

Sure, the IHost is a product that is still in the development phase.

So I’ll wait and see what the community says about future updates;-)

Is there a list of TF cards that are known to be compatible?

Is there a way to roll back firmware to the previous version?

Same here, the sd card is not working after the update to 1.5.5
Sandisk Extreme Pro 64GB v30

The SD card still contains the data:
$ ls -a . .. .containerd .container_data .dockerd lost+found

It doesn’t look like it’s corrupted or damaged

Docker is not able to run

Sorry, we are working on to locate and sort out this issue, will get back to you once we have some clues.

sorry there’s no such list, we are working hard trying to solve this issue.
and there’s no way to roll back to previous firmware.
Please wait for a new update, which is expeceted to be released before 15th this month.
Before the update, please try to remove the card and reboot iHost, then insert the card to see if the problem solved.

I rebooted the device, also then unlinked my eWelink account, rebooted the device, formatted the card in a Windows computer, on. a Mac and in an action camera - three different attempts to change the file system. Each attempt at formatting after inserting in the iHost fails.

The 64 exhibits the same behaviour as my original attempts with a 16GB Transcend card when I first received the iHost.

My iHost had a working TF card inserted when I upgraded the FW to 1.5.5, bad choice, and after that it doesn’t recognize any card, I tried 2, 8, 16, 32, and 64 Gbyte all Class 10 cards but not result. Then I put off and on the device from the top button without a card inserted and after the booting process ended I inserted the card with which it worked before the upgrade, and I noticed a change in behavior, the device recognize that a TF card is inserted but the message Checking the inserted card is displayed on and on.

Hey guys,
Sorry for the inconvenience caused, and we have located it and will release a fixed update V1.6.0 by 15 May.

And before then, here’s the temporary solution to smooth the procedure,

For users who are using class 10 TF cards, please try to unplug the card, reboot the iHost and then put the card back in, this may bypass the unaccessible of the card and docker unavailable issue, we have run a quick and roughly testing that all backs after doing this.

For V30 TF card users, the try out upon may not works, because there is a more complicated compatible issue with the V30 cards, we are working on that and expected to fix it with the V1.6.0 update.

Free to let us know if it works and other issues you may have.


I was wondering: How did you read the content?
Dit you mount it on a Raspberry Pi or so? If so: as which filesystem did you mount it? Any other special instructions to read the card outside of the iHost?

@yitie Thanks for the information! I shared it on the eWeLink & Sonoff User group too:
eWeLink & Sonoff User Group | I just discovered firmware 1.5.5 for the Sonoff iHost is ready to install

Is the eWeLink Group open to the public now? I like to share links to this category more often.

1 Like

Sure, thanks for catching up, you mean this forum? it’s green to go.:beers:

1 Like

I use Fedora 37, so I just plugged it and it was mounted by the OS.
I copied using sudo.

You can read it by using any Linux distribution, use a live distribution if you don’t want to install it.

1 Like

@jeebee @morne @mezeibela63
For your Class 10 card, please try following steps :

  1. (with the not-recognized card inserted and iHost powered on) remove the card
  2. reboot iHost
  3. insert the card
    please try these three steps, see if iHost recognize the card.

That’s how I tried and no result, in fact is a result a no end cycle

hi, thank you for the reply, if possible please download the system logs on a pc and submit the logs via the Feedback buttons in Settings menu.