I host Firmware update

I have installed the latest firmware update on the iHost and on rebooting my TF card now needs formatting, I have lost everything on the card because of this and also because I am currently unable to back it up. Everything I have setup on the card is lost and now I have to do it all again :frowning:

Hi, may I know the model of your card?
please try following steps :

  1. (with the card inserted and iHost powered on) remove the card
  2. reboot iHost
  3. insert the card
    please try these three steps, see if iHost recognize the card.

and please enable system logs and submit the logs via the Feedback button on Settings page.

by the way, you can have a look at this post: Firmware 1.5.5 for Sonoff iHost is available to install - #4 by Teki

Thanks for your reply. I have removed the card but it will not reboot. I will power it down and retry.

The card is a new Sandisk Extreme Plus that has been working fine since I received the item.

in the second step, you can just power it OFF and ON

That’s fine, it now tells me need to format the card, which on first try it just hangs and has no response.

I am now unable to format the TF card. I’m not one for throwing my toys out of the pram but this is quite annoying after it was working well and I have spent considerable time entering data that is now all lost!

Hi Matthewnmoore, sorry for the trouble and bad experience caused, for now, don’t format the TF card because all the docker related data is stored in it, we are trying our best to reproduced the issue and locate it, would you please post a screenshot that the iHost

, that would be great helpful, thank you for your patience and assistance.

Cope that, get back to you once we have something found.

Maybe I’m lucky but I’ve not had any problems with cards, yet…
My messing around mainly involves node-red, MQTT, TASMOTA, and MQTTGateway.
Because iHost doesn’t (yet) offer MQTT, I use a broker hosted on a rPi.

I’ve read the many horror stories on here! I don’t have anything major to lose in the event of a disaster but decided to use the rPi for node-red too.

My iHost is just a zigbee bridge for now. Not what I was hoping for really but I can test things & be safe.

If anyone else works like this you should be aware that node-red runs very nicely on a PC too if you don’t have a spare rPi .


I have just updated the firmware to version 1.6.0 and it still says no card inserted :frowning:

Hi, Please try following steps see if it’s works,
Power off the iHost
Unplug the card
Power on
Initiate the OTA
Plug the card back in after the OTA success

If the issue still exists, please send the logs to us and we will check what’s happened.

I have the same issue like matthewnmoore
I format again in PC, because its cant be formated from Ihost, then reinstall all addons and its works. But when I reboot Ihost problem start agaim, No TF-card.... Formated, reinstalled ... And Iam now afraid to reboot again

May be it’s caused by the not thoroughly formatted of the card, we were notified by some testers have similar issue, that some of the TF card can not be formatted thoroughly by the build-in disk tools of PC, so third-party disk tools like DiskGenius to solve the problem.

Please let us know your card’s brand and model by the way, thanks.

Card is working and formated in previous firmware in Ihost, after 1.6.0. I have that issue. Ihost does not recognize card, doesnt formated anymore. So I tried all tricks form internet bt have to remove it and formated in PC, and after that Ihost recogniye and formated. I install addons again and everything worked until I reboot Ihost. Then again the same, No TF card... Doesnt worked format on Ihost…
TF card is Transcend 16 Gb or 32 not sure

Get, would you please download the logs of the iHost and send it to us via feedback channel, will check with dev-team.

And @Teki please follow this issue.

I`am not sure how send to you this log file
Thank you

Hey there, download the logs and submit via the feedback button here:

1 Like

Follow this to submit the system logs:


by the way, please try to format the card using some card tools like DiskGenius : https://www.diskgenius.com/resource/how-to-format-sd-card-to-fat32.html
Note: please select the correct TF card to format.

Can you please tell me what format to use please?