Trigger ihost scenes from smart devices

Hi, I´m trying to execute scenes program on Ihost from my smart devices and they do not work, they only work when I interact with the device trough the web interface of the Ihost. Can someone explain to me if this is possible? Because the only reason why I bought the Ihost is for this function, so we can kept our scenes locally and do not depend on the cloud/inetrnet service (which is bad in our zone)

Thanks in advance

What kind of smart devices you have on your mind?

Tx keypads and sonoff mini

What are those “Tx keypads”? Give a link.

I Mean the T1, T2 or T3 Keypads

All right. Now tell us what kind of scenes run on iHost you would like to create. What are they suppose to do?

For example I have a aisle with 2 TX on the entrance and other on the exit so I need to turn the lights on from each side, on Ewwlink the scene works fine, but with the Ihos it only works if I use the web interface. But If I touch the TX it doesn´t work. I hope you can understand.

Show exactly how you have constructed your scenes.

Your situation is that when you physically want to turn on/off the light using TX, nothing happens?

TX is a wifi device, which is primarily cloud control. iHost is mainly LAN and local scenes.
In order for it to work as one ecosystem, everything must be able to communicate with each other, and especially scenes must be supported. I speculate and guess that maybe something uses local scenes and something from the cloud and both of these worlds are separate…

I don’t know at what stage the iHost (CUBE) is currently able to support wifi devices and their LAN mode. You can try to block internet access for TX so as to force LAN mode and maybe then the iHost will start controlling them with local scenes.

Unless you have the RF version, the one with two batteries?

Your situation is that when you physically want to turn on/off the light using TX, nothing happens? Yes, that´s right nothing regardles to the scene happen.

Everything is on the same network with WIFI APs and lan connection. So why it doesn´t work?

I use WIFI devices only and all the thevices have the LAN control function ON

It’s good that you have LAN mode selected, but it is activated/used only when the device loses connection with the cloud/internet. And the iHost is supposed to be a local hub and not rely on the cloud. And iHost is primarily zigbee. I still have major doubts whether and to what extent iHost is able to control the device’s WiFi.

At least in my case the cloud always comes first.

The TX is wifi and its scenes are handled in the cloud. I don’t know how the iHost behaves with local scenes… But I still think that the iHost is simply not able to control the TX within local scenes.
For this reason it would be good if you forced your TX to LAN mode…

On the other hand, you say that everything works the other way around? With the iHost, are you able to turn your TX on/off? But the TX is not able to trigger scenes?
And does the TX physically have some light connected to it? Does it work? Or do you use the TX only as a remote button?

I would still like to see the exact logic of your scenes in relation to the TX, because otherwise I can only guess…

If you haven’t done so yet you need to go through these steps…

Sync the SONOFF LAN Device

eWeLink Smart Home Add-on Tutorial


eWeLink Smart Home can discover eWeLink WiFi devices in LAN. After login with eWeLink account, you can sync the device you chose to eWeLink CUBE. By eWeLink CUBE, you can control the device in LAN and link the Zigbee device in eWeLink CUBE with the scene.

From the Ihost I can operate the Tx without problem, even the scene created works. But as I told you when I use the TX physically the scene do not work, it only turn on the light that is connected to that TX. I would make a graphic for you to under stand the scene that I need.

Once again you do not show the current scenes… a screenshot would be enough, but if you do not want to.

Create scenes where IF TX1 THEN on light. And the same for the remaining TXs and for off unless the option is reverse.

Oooohhhh Sorry!!!
The thing is that I´m not at home so I can´t connect to the iHost right now
Tomorrow I´ll the a screnn shot and show you

hi, please send feedback on the iHost settings page, and please attach the system logs, we’ll look into the issue.

What about the storm that was supposed to happen in May? Are you going to look into that issue?

if you are talking about what @ward said, it was just a joke. :flushed:

1 Like


Customers vs. Company


1 Like

morgan here is one of the scenes that not worc from the smart device

Here are the settings, Which logs you want me to send you?