[IHost] - Smart scenes not working

I bought a sonoff ihost recently, the most important things for my choose was the possibility to run my scenes locally, but this feature not working properly, sometimes works, but in the most part fails.

I thought that could be a problem with my wifi network, but it’s not, because if I use the smart scene from ewelink app’s works well.

I’d like to know, if someone passing for this issue and if Sonoff team’s already identified this problem?

I am not sure why this would happen, but I think it would worth detailing your experience. Like is there a specific scene that does not execute? Is it a specific step? What is no working in iHost which is working in eWeLink?
Maybe add some screenshots of the scenes that are affected.

Hello, which device model are you using in the scene?

Hi, yes, in eWeLink the scenes are working, but not in iHost, are simple scene, just to working like a parallel switch, some scenes working in iHost, but the most part is failing. I have more than 20 Switch TX t2 e some Sonoff mini, I’d like to have all the scenes local, works for some times, but stop without reason.

Below is a example:

This same scene configured on eWelink App is working, but if a disabled in eWelink and configured by iHost, it’s fail.

Hello, are Sonoff TX T2, thanks for the reply.

Have you upgraded your iHost and ewelink smart home add-on to the latest version?

Add: The latest version of iHost is 1.13.0; the latest version of ewelink smart home add-on is 2.0.0.

If there are still issues with the latest version, please submit feedback and your system logs via the help center and we will assist you in investigating.

Once the smart home add-on has been updated to version 2.0.0, you will need to log in to your eWeLink account again. The update logs you out.

1 Like

Hi guys, I was using the version 1.12.0, I’ve updated to 1.13.0 and also updated the eWelink add-on to 2.0.0, it was necessary to log in again. I’ll make some tests to see if the problem was solved.

thanks from Brazil.

If you still have problems you can error check if you activate the device in Node Red. First you recreate the scene in Node Red then add in a loop to retry only if it fails, which you can try a set number of times at set intervals if you install a counting node using the palette installation. I can’t remember the loop I made but it’s overly complicated. I made it early on and now I copy and paste it because I know it works. One day I will create a neat version and debug it.

After the last update to version Ewelink Cube v1.13.3 and eWeLink Smart Home to latest version, my scenes are working perfectly.

good job guys.


1 Like