iHost - Scene triggering wrong

I have this scene here in my iHost (4Gb):

If I press the SNZB-01 and the Smart Wall Switch (TX-T3) is OFF, then it should trigger the TX-T3 ON with a sequence of on/off.

It’s working well, but if I turn the Smart Wall Switch ON, it’s also triggering the scene, and if I try to turn the Smart Wall Switch OFF, it turns ON immediately once again:

According to the scene, it should trigger the scene ONLY when I press the button (SNZB-01) and not when I press the Smart Wall Switch.

Even with the scene OFF, when I turn the Smart Wall Switch ON, it start the scene :frowning:


Please send us your system log in here or via feedback.
We’ll pinpoint what’s wrong.

Thanks, please see the system log on Ticket # 211574

There’s two problems you mentioned.

  1. The scene is abnormally triggered when the control switch is turned on

We are not been able to find the issue in the logs, all triggers in the logs are acting normal.
Please reproduce the issue then upload the log again.

  1. The scene is still triggered even after it is turned off

We have not found this problem in the logs so far, but we can see that you turned off the scene around 15:42 on the 29th, and there is no more logs related to the execution of the scene after that.
Would you mind provide a video of the scene being triggered even after it is closed?
Then again, upload the log after reproduce the problem.

At 17:27:17, I pressed the light switch (Sonoff TX 3-Gang)

At 17:37:55, I tried to turn it off, but as you can see on the log it turned ON again.
Doesn’t matter how many times I press this light switch, it insist to turn ON again.

See the video:

Then, it decided to follow a sequence of ON/OFF that it should not do!

This sequence of ON/OFF should be done only when I press the SNZB-01 and not the Light Switch.
By the way, this scene is OFF:


I’ll submit the log once again. See the log between 5.27pm and 5.53pm

I guess I found the root cause:

Note that the condition is “if all conditions are met”

So, the trigger must be:
When SNZB-01 is clicked AND the light switch is OFF, then do something...

But the code in iHost is also triggering when the condition is:
When light switch is OFF and SNZB-01 latest status is "click", then do something...

On Sonoff NSPanel Pro I don’t have any problem, while on iHost there is the problem described on the previous post.

But you also need to investigate why this scene is running even when the scene is off.

Found the problem:

I set the NSPanel Pro to repeater and it has been unlinked from my eWeLink Account, but the scenes remained on the eWeLink account.

The SNZB-01 has been unlinked from NSPanel Pro but the scene remained with the light switch only.

So that’s why the scene is running even when the scene is off?

Wireless button only have one status which is click.
Therefore, the scene can only remember is that current status of it is click, so when light switch is off, it fulfilled the condition…

I guess SNZB-01 has: “click”, “double-click” and “long-press”.
After each event, shouldn’t it return to “waiting”?

Exactly. After removing the scenes from eWelink app, all has been solved.

I guess it’s a good idea to add a feature to import the scenes from the eWelink account when we sync iHost with eWelink Smart Home add-on.

I though that when I set NSPanel Pro to work as a repeater, it should delete everything (even the scenes). That seemed to be what the warning said.

Did you mean when you turn the light switch off and didn’t click the SNZB-01 then the scene still executed?

That’s right. I was mixed it with some sensor.

It was executig because there was a scene on eWelink APP (on the smartphone).
After deleting the scene from the eWelink app, iHost is working as expected.

On the smartphone, the scene was:
When the SNZB-01 is pressed AND the light switch is OFF, then do something...

SNZB-01 was paired to NSPanel Pro.

When I set the NSPanel Pro to work as repeater, the SNZB-01 has been removed automatically and the scene changed automatically to:
When the switch is OFF, then do something...

So both of the problems are caused by the scene that you previously set on EWeLink App?


Suggestion for eWelink app:

  1. Import the scenes also to iHost when we sync it using the eWelink Smart Home add-on, so we can see duplicated scenes;

  2. When a device used on a scene is deleted, the whole scene must be deleted as well (automatically).

Can anyone assist. I have a Sonoff SNZB-03P and it is set to Detection Period of 10Sec. I tried some automations on iHost to have the light ON and delay 5 Minutes to turn OFF. I would like the light to stay on while the sensor detects movement. Ie I am in the room.
In other words I would like the detection to trigger the routine to re-start the 5 minute timer every time it detects motion.
I can do this in Home Assistant but my Zigbee devices are linked to the iHost.
Any suggestion will be welcome

in ihost you need to make 3 scenes.

1st scene - wait a 5 minute, turn off the light.

scene 2 - (SNZB-03P) motion detected, turn off scene one.

3rd scene - (SNZB-03P) no movement - turn on the first scene.

A single scene is enough, similar to this…
I don’t have the SNZP-03P, so I eddited the “If field”:

A single scene won’t solve this.
If, say, after a minute the snzb-03p detects movement, it won’t stop the scene that was started earlier.

The lights-out scene is only supposed to happen when someone leaves the room and doesn’t come back for five minutes.

What you described works. But if we return to the room before the 5 minute time, the light will turn off while we are in the room.

Thanks, I will give it a try now.