Sonoff L3-5M won't connect to WiFi

same problem here, I have 10 led strips installed, keeps disconnecting randomly. Already had sorted out the Legacy mode issue on the router, still experimenting with advanced wireless router settings, but no luck. If you guys get a response from the support ticket please let us know.

1 Like

At the end, Sonoff offered me a discount code to purchase L3 Pro and to replace L3 led strip. I can’t remember, but it was something like 20 or 25% discount.
They weren’t able to fix mu issue.

1 Like

I’m using L3-5M-P

2 Likes

Same here. I bought 3 strip (L3-5M-P) and they are unable to connect to the WIFI 2.4Ghz.
After a lot of searches I think that the problem is related to the fact that this led strip supports only 2.4Ghz but with only 802.11b (other sonoff WIFI devices supports 2.4Ghz but also 802.11g or n).
802.11b is an acient standard (1990) and it is removed from modern routers (i.e. fritzbox 5530 and others).
So my question to sonoff tech support is: would be possible, with a firmware update, to support a more recent 802.11 standard within the L3-5M-P controller? Otherwise I suggest to sonoff support to clearly write this limitation in your product specification. In addition I have to throw out the strips.
I hope someone will answer.
Thanks
D

4 Likes

well,
i have the same problem with a L2 strip. I have UBNT’s UNIFI access point…
here are some strange facts…
device is connected, gets ip address, but it is not shown as connected in ewelink app.
Screenshot 2023-11-05 at 5.16.00 PM
this is a screenshot from my mikrotik router… device is connected and gets ip from dhcp server.


Screenshot 2023-11-05 at 5.16.29 PM
these are screenshots from the UNIFI controller…
the result is the same… device is not shown between others in Ewelink app…

2 Likes

well, i’m sure it does not have to do with the wireless protocol.
i had an L2. Yesterday, I bought an L3-RGB and i have the same issues.
they connect to the wifi, but the are not displayed in ewelink application.
i setup a Mikrotik AP, just for the experiment, only in 802.11b, take a look…
you can see the mac addresses (D0:27:02)… connected, but nothing in Ewelink application…

3 Likes

I had to try every legacy router, They won’t work anymore.

Support not support us as expectation.

2 Likes

Same problems here (also in Greece just in case…). Got two L3-5M-P strips. They came with firmware version 1000.2.1060. Bluetooth only so far, no WiFi, no matter what the settings are. They do get an IP address and show on the local network, but apparently the app is unaware of the connection and, of course, they are offline in Google Home.

I also have B02-BLs, B05-BLs and DUALR3 Lites, which are fine so far and B02-Fs which fail to upgrade the firmware (for months now stuck to 1.3.2 with 1.3.5 “available”).

I’m not even sure if anyone from Sonoff is reading this.

Some more info, after “enabling” Wi-Fi, the initially disabled “Schedule” and “Timer” are enabled, but fail to save.

It’s a pity, because the products seem to be of good quality, destroyed by poor software.

PS: As as was writing this, one of the two strips suddenly appeared connected and worked for a few minutes on the Wi-Fi network before going offline again… Weird. Definitely not the quality of the Wi-Fi (its less than 1m away, with little interference).

PS2: The blue led on the module blinks twice per second, which, according to Sonoff, means connected to the network but “Failed to connect to the server: Network interrupted or DNS cannot resolve the address”.

  • a. I can visit the internet
  • b. The bandwidth is by far free.
  • c. The SSID I’m connecting to is unique,
  • d. There is a single DHCP server on the network,
  • e. ARP is not attacked,
  • f. No firewall between the strip and the internet (at least not that I’m in control or know of ;-),
  • g. DNS server inaccessible (I’m inclined to think this is the case…, but I don’t know what is the urn the strip tries to access. The only record I see from the strip is to eu-dispd.coolkit.cc which resolves to 35.156.2.11 (an OpenResty platform, that seems to respond. BTW the failing to upgrade B02-Fs are connecting to 52.57.99.135. Both are AWS servers in Frankfurt).
  • h. No IP address conflict.

It definitely looks like a server-side software/configuration problem, and not hardware.

This is Sonoff’s unofficial advertising slogan. :slight_smile:

About 30% that someone will notice.

Sonoff/eWeLink uses Amazon’s cloud, so it will always be one of their servers that is reasonably close to your geo-location.

Generally, Sonoff products need outgoing connectivity TCP 443, 80, 8080, UDP 53 for DNS.
The domains they often communicate to are usually: *.compute.amazonaws.com *.elb.amazonaws.com *-dispd.coolkit.cc *-api.coolkit.cc *-disp.coolkit.cc

What can I do to help you, nothing really, I can repeat a spell like start over.

Delete devices in ewelink app, log out, clear app data and check if you have 5.1.0
Reset the devices to factory settings. Run the app, log in, and try adding again.
Before you start pairing the devices, turn on Wi-Fi on your phone and connect to the 2.4Ghz Wi-Fi network on which these devices are to work.

If pairing was successful, the device should connect to WiFi.

Do you see them connected on the router side?
Did DHCP assign them an IP?
Are you able to ping their address?
Do you see traffic on the WAN port to the domains listed above?
How long do devices stay connected to WiFi?

Some Sonoff devices are incompatible with some routers and tend to not connect to Wi-Fi or drop the connection after a short period of time.
I have observed this behavior with S26R2 on typical SOHO routers from several ISPs. On your own equipment with OpenWrt, the situation is fixed by enabling


Without this feature, my S26R2 simply couldn’t work with several different wifi routers. they went crazy, lost connection or were unable to connect.

This is some strange problem on the fw side in some sonoffs. Either a bad fw or a bad wifi chip. But no one has fixed it for a long time and probably never will.

Do you see available fw updates in the app and device tab?
Can you do an update?

Another behavior from my observations… some Sonoff devices cannot update without any problems.
The update progresses to a certain % level and then stops and stays like that for a very long time and nothing happens. In such a situation, I wait 5-10 minutes and then disconnect the device from the power supply and plug it in again, and often it will already have the FW updated, even though no one has reached 100% from the software side.

If you have a paid plan, you can also try updating in WEB, but if the device does not connect to the cloud, this option is pointless. :slight_smile:

If you have a VPN, change the exit node to other countries and try.

Indeed, the devices do connect to my LAN, they do get an IP from my DHCP, and pings are stable and with a reasonable latency. There is a bit of jitter, but nothing excessive, and I can also see their DNS requests going through my forwarding DNS server. I don’t have a network sniffer right now, but I’m fairly sure the problem is on the server-side. A bad certificate? a non-responsive service? who knows… This corroborates the fact that one of them suddenly came online for a couple of minutes yesterday and I was able to control it through eWeLink Web. This would be unlikely if there was a problem with the software on the device itself. Much more likely to happen with the service software.

So are you 100% sure that the WiFi connection is continuous? Why am I asking this because if you read @Undeene posts

You can see what I mentioned earlier, i.e. setting “enable legacy rates”

Which, according to him, had a positive impact on Wi-Fi connectivity.
The only thing I disagree with is that other Sonoff devices do not have this problem, some do. But in general, I sometimes tell people the same thing: if the Sonoff device has strange problems with WiFi, this may be it.

But maybe you don’t have a problem with WiFi. However, if L3 connects to the WiFi router, watch for how long and whether it loses connections. Ping for 12H or something…

Then it’s possible it’s something on the cloud side, it wouldn’t be the first time…
Have you tried adding one device to another/new ewelink account?

Only the sonoff/ewelink team can actually provide more help here if it’s a problem on the cloud side…

Fairly sure this is NOT a Wi-Fi problem, but a cloud service one. All symptoms point to this. From the device showing stable on the LAN, to the blinking of the blue LED. It could be a bad configuration on the devices (for example a very short timeout to get the response from the service), but still this does not explain why the device shortly came online. If I had the time, I’d setup a sniffer to monitor the traffic to/from the cloud service.
Also I don’t really understand why companies don’t offer the possibility of a “local” (LAN) service. Sure, it’s not for everyone, but in cases like this it would be of help, the devices would be more responsive, and the companies would have less load on their cloud services. Kind of what Plex does? I don’t see any real reason why turning my bed-light on should get routed through Germany, China or whatever…

Also, when you say that enabling b mode fixed it for you, it seems that in your case, the antique b mode was not enabled previously. You just enabled it along with the others. In my case it is already enabled on the 2.4 SSID (mixed b/g/n/ax), and also I did try just b… No luck.

Because most IoT for home is a typical cloud mess… Some Sonoff devices have LAN, although they still require the cloud in many aspects, unless it is replaced by iHost, which is currently also far from perfect.

In theory, Matter is supposed to be just such a standard, preferring LAN first, but even here there are problems with compatibility.

Seems like an active topic again, so here is a status update:
Since I turned on legacy baud rates (which is not normal these days to be turned on), device started to connect. I believe that there is no need to explain what are legacy baud rates, and the impact on 2.4 GHz performance.
However, in random intervals it still keeps disconnecting for a few seconds (sometimes longer) and gets back online (attached photo is just a part of the log). It’s not ideal, but it’s somehow usable. I can control it, and from time to time I have to wait for the device to get back online.
Also, request for an active bluetooth connection even when it’s connected via WiFi is still there.

As I could see, the main issue is that L3 strips (both pro and non-pro) are using OPL1200 chip which supports only 802.11b, with WPA/WPA2 security standards. I’ve mentioned earlier that Sonoff offered me to purchase the pro strip with a discount code, but I think that it would be the same.
Besides this, even and when we manage to get the connection, why is it unstable and keeps asking for an active bluetooth? That just doesn’t make sense.

This morning both devices were intermittently able to switch to Wi-Fi mode, if only for a few minutes, did show up on Google Home, and I was able to control them not via BT but via the internet. The WI-FI network settings were as usual: a mixed b/g/n/ax. While they appear online, the blue LED is constantly on (as Sonoff says: indicates a connection to the cloud server, while a twice-a-second blinking shows connectivity to the LAN but not the cloud). When the device appears offline in the app, it is still connected to my LAN/Wi-Fi, just not to the cloud service. After a while, apparently they don’t try to reconnect, and the only way to reproduce/try-to-reconnect is to change to a different Wi-Fi SSID and back, so they try the cloud service again (my router has 8 SSIDs).

Legendary software quality by Sonoff… :slight_smile:

I was thinking about getting L3-P in December, but the whole situation really discouraged me.

1 Like

While both strips are online


(sadly, it lasts only a few minutes and they revert to BT. Then I have to switch SSID for a few more minutes…):

@Daniel_Zhan Maybe some official comment…