Sonoff L3-5M won't connect to WiFi

Hi all,
i just got the Sonoff L3-5M led strip and I have issues with connecting the strip to my WiFi.
The strip can be added via Bluetooth easily, as you can see from the pic below:

When I open the strip from the eWeLink dashboard I get this message:

This should be ok too, it says that there’s a new firmware and that i should connect to the WiFi in order to get the firmware upgrade. When I tap on the “Got It” button it moves me to the Wireless Settings.
However, when I enter my WiFi details and tap on Save button, it just return an error:

I can control the device via Bluetooth (turn on, turn off, etc.), but it won’t connect to my WiFi at all.
You can find model details on the photos below:

Please note:

  1. I have several other Sonoff devices on the same WiFi (WiFi is 2.4 GHz)
  2. I have tried to remove the device and do it from scratch several times
  3. I have also tried to connect the strip with Fusion Link enabled
  4. I have tried with several power adapters (5V 2A, 5V 3A)

Please advise.
Thank you in advance.

1 Like

Did you try to change wifi from the WiFi Settings shown in your screenshot? give it a try to see if it connects.
(and if you have 2.4Ghz and 5Ghz with same name, please seperate them)

1 Like

Thank you for your reply, Teki.
Yes, I’ve tried with another WiFi and with another mobile phone.
Just for reference, I already have 2.4 and 5 GHz separated. I’ve created one 2.4 SSID just for smart devices. Also I’ve tried to change WiFi password on the router, and tried with changing WPA encryption. Nothing worked.
On all mobile phones situation were the same.
Over Bluetooth everything is working fine. I can control everything except the WiFi connection.

1 Like

Also to add, is there an option to flash the latest firmware over usb, since L3 has a USB-C port? Perhaps a firmware update can solve this issue.

ok thank you for the details.
Try to update the firmware on ewelink web:

And if still can’t connect, try to create a hotspot wifi on your android phone to see if the light strip can conenct to this hotspot.

1 Like

Thank you Teki for your suggestions.
I’ve managed to make a connection. I had to enable legacy 208.11b rates in the router WiFi settings.
I would like to know, is this a bug since all other Sonoff devices are working with enabling 208.11b rates, or it should be like that?
FYI, I also have several BasicR2 switches, POW Elite, Sonoff Bridge, etc. All of them are working fine on the same WiFi. I had to enable legacy rates only for this L3-5M strip.
Thank you for your time.

In general, IoT devices that require higher bandwidth and faster data transfer rates, such as security cameras, may support newer Wi-Fi standards, while those with more limited requirements, such as sensors or smart switches/lights, may only support 802.11b.
It is suggested to set your wi-fi mode to 802.11b/g/n mixed to compatible with all devices.

1 Like

After some additional testing, here are some additional details:
as soon as i get without internet connection (access point stays on), L3-5M goes to bluetooth connection and stays there until I reboot the device (power off then on). Only then it reconnects to WiFi.
I’ve tried to manually connect, but it’s not working. Device stays on bluetooth connection.
All other Sonoff devices (pow elite, zigbee bridge, R2 switches, etc.) remain connected to WiFi.
Seems like L3-5M is not smart as it should be :slight_smile:
Not to mention all the troubles I had when I got it at the beginning. Only for this device I had to enable legacy b rates.
Please note, I already had 2.4 GHz WiFi on b/g/n, but I had to enable additional b rates to make it work. It doesn’t work with standard rates, which were strange considering that all other Sonoff devices are working fine without it.
Any additional tip for the loss of internet connection issue?
Thank you in advance.

Some additional details which may help in resolving the issue:
LED strip goes offline regardless of internet connection status. It just happens randomly.
Here is the SSID status:

And here is the L3 firmware version:

Hello. Same problem here.

I received the led strip today and the controller will not switch to wifi in the app.

It gives me a message for an update for the flickering…

When trying to update firmware, the device appears offline because it reports not connected to wifi.

However, the wifi hotspot appears properly connected in the wifi settings

On top of this, the device appears in the client list of my wifi router.

The settings of my wifi hotspots are fine and compatible with the requirements of this device. The device connects to th 2.4 Ghz hotspot and does not disconnect until I turn it off.

I have a Wifi6 router but also tried with a Wifi5 and a Wifi4 router. Same results. I tried with an older Samsung tablet, same problem. I also tried 3 different smartphones, the device remains on bluetooth and will not switch to wifi.

I need a solution, otherwise I am planning to return this ledstrip immediately for a refund, because not switching to the wifi connection when the device connects to my router is a dealbreaker for me.

Any suggestions?


1 Like

Everything is the same with my device, except that at the end I managed to connect it to WiFi, but it disconnects randomly where the only solution is to turn the led strip off and on again.

The question is obviously, how did you manage? :smiley:
I have to test this if possible, mine might remain connected.
If it disconnects, I am not willing to go around the ceiling to unplug
whenever it disconnects, I would rather return for a refund and get
myself a more reliable led strip.

I had to enable legacy 802.11 rates on my access point… If you have that option try with that.

I also have 2.4, 5 and 6 GHz WiFi in my home, several APs with separated gateway, dns and dhcp servers.
Every device until now worked without any issues.
For gateway I’m using opnSense, and for APs OpenWRT. Network is working perfectly.

As you probably have seen in the photos, there is no “legacy mode”. However, all network protocols are enabled, b, g, n, ax. I tried with a repeater, no luck. I also tried with an older wifi router, same problem. All other wireless devices (35+ devices), including other Sonoff products work fine on my existing hotspot. I will not buy or add a dedicated wifi router for this led strip, I prefer to return it for a refund. If Sonoff wants to install an extremely old wireless protocol that is nowadays unusable in today’s led strips and wifi environment in general, I would rather buy another led strip instead of trying to find solutions and wasting my time. Sonoff not even using Wifi1, the 802.11b from 1999 but opting for legacy Wifi from 1997, is so disappointing. From the 4 already surpassed 1-4, they chose legacy wifi. This speaks for itself. Some people will not even find a wifi router this day to connect their led strips. The box says the controller is 802.11b which we now know it is not true. In fact its misleading. 802.11b is supported from all my wifi hotspots, legacy 802.11 has no letters after the 802.11.

I have to add this also. I opened a case here to get help from other users about a Sonoff TX T2 EU wifi light touch switch and they unlisted my topic that was posted in help and feedback. This action only shows they do not care so much in helping customers or receiving feedback when something goes wrong.

The link for this topic is here. If you know something about this matter, let me know please.

Thanks Undeene for your time.
Hvala puno i pozdrav iz Grcke.

1 Like

Unfortunately I can’t ask for a refund since it would be much more expensive than to order another one, and I am not planning to order anything until I get a proper reply which will at least explain what is going on here.
Regarding your other issue, I’m afraid that I cannot offer you any smart advise, I can just hope that Sonoff support staff will resolve it as soon as possible. BTW, those switches are looking awesome :slight_smile:
Hvala i tebi, i pozdrav iz BiH :slight_smile:

1 Like

I can return for a refund in GR, the purchase is local and I can return the item within 14 days if not satisfied, no questions asked. But still, this is an item that does not perform as expected and it is only 5 days in my hands. I will opt for another led strip.

I am not saying the ledstrip is bad, but the wifi protocol chosen in the controller, is ancient in wireless terms if it is a simple 802.11.
The box of the led strip says 802.11b. Legacy wifi does not need to be present with 802.11b, unless of course the 802.11b exists only in printed paper.

Some other brand led strips work great when it comes to their connectivity but the controller fails and others have a problem with the strip and the leds itself. It is very difficult to find a good and reliable led strip, whether RGB or RGBIC. Other led strips I have used were TP-Link RGB, similar to this Sonoff. I bought 4, the controller in 3 of them died in under 6 months. I find this to be a pattern so I requested a refund for all of them and managed to get my money back.

Producers need to make reliable devices. It is better than making them cheap. The long term reward is much more profitable.

As for the reply, I really wish you good luck. My other support topic where I was asking for help, got unlisted by an admin and the topic now has a private link. This means you cannot find it unless you know the link to it. How am I supposed to get help here? I was told to raise a ticket. I raised a ticket on 21 January 2023. I got an answer 15 days later where I was asked things I explained in detail. When I replied explaining the same things I wrote in the first place, asking support to read before answering, I got nearly the same answer, plus more of a confusion from support which sounded as if they were writing to another customer. I asked for someone who can read and write English so we can communicate properly, I even made 8 videos since words were not understood, and I have received no answer since February 10. Two weeks now waiting for some kind of “support”. So when I wrote in this help and feedback forum, they unlisted my topic making it private. They left a message asking me to raise a ticket “especially for software-related issues”, when the problem is not software but hardware. Needless to say that I have already raised a ticket as I wrote. It is more than 1 month now they cannot even understand what I am writing, not to mention they are not replying to my ticket last 2 weeks, athough I have sent 2 reminders in this time. But hey, raise a ticket and we will remove the post in the meanwhile so you can get no help at all. :rage:

So once more, good luck expecting an answer in the problem, even more good luck if you raise a ticket. :unamused:

Switches are great, this 1 bad out of a total 10 switches, really kills me though…

Any advise? Thank you in advance.

Is there any news about that problem?
I have two L2 strips and they worked perfectly for around 1 month. Then 1 strip disconnected from wifi and wouldn’t connect it anymore. Only bluetooth control.
I deleted it from ewelink and tried to pair it again but cant anymore. So now i can only control it with remote.
Another strip disconnected from wifi and looks like same problem. Can control with bluetooth and wont connect to wifi. Im not gonna delete it from ewelink this time, because i dont want to control it with remote only.
but bluetooth and remote connection isnt what i want with these strips.

I have an active support ticket but no good so far.
No matter what I write or ask, I always get the same response from the Sonoff team, follow these steps…etc.etc.
Even when I answer that I followed everything and nothing worked, I get the same answer again.
The strangest thing is that even when the L3 strip is connected via WiFi, as soon as I open the device via the eWeLink app, it asks me to turn on the bluetooth connection. It doesn’t seem to recognize that it’s already connected via WiFi (besides the main issue of randomly disconnecting from WiFi).
I get the impression that everyone just reads the last comment or email, and responds based on that information.

1 Like

Well, I have the same problem here. This makes the equipment useless. Let’s wait for the support ticket, but for now, the LED strip will stay in the drawer.