Problems with ewelink smart home IHOST

Hello every one.

Anyone else is having several problems with ewelink smart home from it last update? Im having problems to manage wifi devices trought ewelink smart home, many “off line” messeges from devices. Ihost reboot 1 or 2 times per day byitself, then ewelink smart home use to fail. For example, right now, I logged out to try to log in again to solve some problems, but i can not log in again…


Would you mind sharing the log of the add-on with us? So we can further navigate the issue.

Thanks in advance.

OK, can you tell me how can i share logs with you. already downloaded then from Ihost, but what is the most safe way to share then with you? thanks in advance.

Hey Google drive or Dropbox would be great, you can dm the link.


Hi there, Please find bellow wetransfer link:

Today, service has been half working for example. Some wifi devices has been working fine, but some others no. Maybe you could see it on logs. Many thanks anyway.

Make me know if you has received then properly . Thanks


Thx for your time, will keep you in the loop

Did you try reboot the add-on?
Can it fixed the problem you mentioned?

Hello Suika,

Yes i tried to reboot it, i logg out and then, log in again, i reboot the ihost also, but the main problem is some of wifi device added through ewelink smart home doesn’t run properly, every day get “failed to control” message from any of then.

Another good data is, over ALEXA, with ewelink skill, i can manage devices which fails with Ihost…

The log indicated that the control failure are due to device unreachable.
Is the problematic devices are far away from iHost?
Is the network condition stable?

No, those devices are WiFi, and they are quite close from router. In fact, I can manage thought Alexa, but not via IHOST. That make my IHost scenes useless. I repeat, I’m finding this problems after last update.

These devices are control via LAN instead of cloud.
I can see one device 1000fbae8c was failing many times(22 times out of 46 control).
Is the device any different from other devices?

Hi Suika,
No, this device is a sonoff basic R2 with its last version 3.7.6. It is installed about 1,5 meters from the router. In fact rssi is strong right now as Ihost tell me.

Im right now trying to ON/OFF devices (10003be9a2 and 1000fbae8c) from IHOST, and message “failed to control” appears always. But if i tried to do the same in ewelink app, devices works perfectly and feedback status is showed on Ihost icon!!

Just an note!, when i updated to the last version, ewelink smart home, Ihost , as device, disappears in my devices list on ewelink app. Could be related? Thanks so much anyway.

The devices you synced from smart-home are controled via LAN instead of cloud.
And eWeLink app is controling device via cloud as well as LAN.

When you control fail, try control it via eWeLink app.
And take a screenshot of the homepage.
The icon on the upper right will tell us what mode is the device in.

What is the previous version of you iHost before upgrade to 1.13.7?

Me, too. (I think).
I have one Sonoff Switch R2 that just dropped offline. I’ve tried everything. Reset to default, delete the device, re-pair, DIY Mode…

I do get the Switch R2 to take my WiFi credentials and it appears in the EweLink app, but it also says: “Offline”.

I turned off 5GHz in my APs, and the nearest AP is about 1M from the switch, so I doubt that signal strength is the issue.

Is this the same problem as the OP has, or should I just flash the switch with ESPHome?

Hello Again,
after making some testing i realise that IF:

  1. I disable the lan mode in every device in ewelink app.
  2. Restart the Ewelink smart home
  3. wait about 5 minutes
  4. Devices goes online again
  5. if someone not, switch off and on from ewelink APP
  6. Then, i can get all devices work again

BUT… If Ihost reboots for some reason, external or not, a need to do every step again to make it works, and this is very often unfortunately.