Failure to control eWelink devices on iHost

Fellow eWelink fans…
I have been using eWelink Web and App to control a Sonoff ecosystem of roughly 60 devices for more than 2 years to control pumps, heating systems, water levels, lights, access control, security and so on. By now I have learnt how the ecosystem works. I have an advanced network, all devices are LAN enabled, on the same network with strong WiFi signals. A bunch of smart scenes, all working very well, like clockwork.

Two months ago, I installed the iHost RV1126, now running firmware version 1.9.1. Successfully installed the eWeLink Smart Home add-on and synced 57 devices. all good so far… I can see all the devices on the iHost. Set up rooms and allocated the devices - all good.

However, trying to switch a device on or off (any one of my many different types mini R2/R3, Pow R2 R3 etc) results in a delay followed by message "“Failed to control”. Sometimes the status of the device changes after some time, sometimes not. Controlling the same device in the eWelink app or web is accurate and instantaneous (all set to LAN control). iHost eventually catches up with the change of status (often a minute or more later) and then displays it correctly. Often a device would show offline in iHost, but even so I can control it via eWelink app without problem. Eventually the iHost shows it as online again - in one instance just now, 3 minutes later! This makes absolutely no sense - I can see the devices on my network management tools and they are all on the same network with the iHost. The fact that they eventually display the correct status indicates that it is not the network.
I tried setting up and running smart scenes, but they fail (obviously due this problem). I did try rebooting and all the obvious checks were done - it makes no difference.

Anyone with similar experience, or perhaps even a resolution?

Right now, this device is kind of useless to me and I will continue running on the eWelink app and web… Hopefully the iHost will live up to the promise of a local host in the true sense one day - looking forward to it. Kind of disappointed with the stability, feature set as well as user interface.

Having the same issue,first it was working ok ,i had issues with rf bridge sensors and now after some update situation has improved with sensors but lan devices expiriancce has degraded,this addon need masive overhaul

Hi, sorry for the trouble caused, can you help to submit the system logs for analyze?
please refer to this guide to submit the logs:
@fruvita67 @pierred358

Hi Teki
A support ticket (190121) has been opened with the log attached and some additional info about my environment.

The ticket does not attach the log yet, please double-check. Thanks

Hi Daniel - I replied to your email but it is being rejected for some reason. I created a new ticket directly from the iHost feedback link, with the log attached.

1 Like

Got it.

Thank you @Daniel_Zhan for the support. I will let Daniel explain, but basically the problem has been identified to be related to eWeLink add-in log size management and will hopefully be fixed in September. It seems it is not an issue with the iHost itself, but with the eWeLink add-on. Users would experience the problem as a gradual slow-down of the eWeLink Smart Home add-in, until it becomes almost non-responsive in my case. With the 57 devices that I control, I probably just hit the issue faster than many others.

This process and interaction with Daniel proved to me that the support process works and I have faith again :slight_smile: We must just provide as much relevant information as possible, and of course the logs…

The work-around to get my system going now was to uninstall and reinstall the eWeLink add-on. This was quick and the system automatically re-synced all my devices after providing my eWeLink user ID and password.


Hello. I have the same problem and i tried twice to uninstall and reinstall the ewelink add-on but still have the problem…
I don’t know how to control again my Sonoff switches with iHost ?

Sorry for the inconvenience. Can you download the add-on log now? Or is it still impossible to download?

Hi, pierred, can you tell me how did you exactly used the device syned from eWeLink add-on? For instance, use them in Scene or Security? With how many devices? What’s the scenario you used them in?Replied with pic will be more helpful. So we can reproduce it in our end and pinpoint the problem ASAP. Thanks.

Hello Suika

First, I must explain that I have been managing all my devices via eWeLink app and web for a couple of years, and have quite a few scenes to control a lot of stuff.

When the iHost was available in South Africa I immediately ordered one, because I was interested in the local control capability. All my devices run current firmware, the iHost is on 1.9.1 and I have a strong network deployment using a TP-Link small-business design.

The first step when I implemented the iHost was to install the eWeLink add-on, and sync all my devices. This worked well.

I did not immediate move any smart scenes, and just played with the iHost – just manual control of device like switching lights off and on and looking at cameras (GK-200MP2C). Just doing this after a while I started noticing “could not control device” notifications and the status of the device not shown correctly. Sometimes showing offline mode when it was really online. Then I set up a few schemes, and disabled those same schemes on eWeLink so they do not “fight” for control. I noticed then that scenes were not executing and eventually realised it was because of the delay in status updates. So I switched the scenes off on the iHost and enabled them on eWeLink app again – happiness……

After that I reported the problem and went through the process to delete and re-install the eWeLink add-on. I could control all devices properly and the status was correctly reported. I could also at that time view the log on the eWeLink add-on console. I dod not try to enable the scenes again – was just playing with manual control to test.

After a few days the problem came back and I got “could not control” messages again. The status of devices were showing incorrectly again, and it started taking a long time to see the log. Eventually I cannot see the log anymore (it times out I think) and I cannot effective or accurately control devices. It is as if the process to get the status of the devices is getting slowed down or maybe not working at all. I do not know how your code works, but I see a LOT of status updates in the log…. Maybe the process is waiting for the previous status check results to be written to the log, but because the log is massive it delays everything?

I do not see high CPU or memory usage – only when I try to access the log will the CPU go up to 60-80% but when it times out it drops down to around 20% again.

To answer you question directly – I did manual control, tried to use scenes, but did not set up security at all.

Hope this helps


Thank for the reply, pierred. Is your control delay and failure was happening after you set up the scene? If so, can you send me the exact setting of your scene? Best with the exact device and setting, thanks!

I confirm the problem. It can be solved by rebooting the router. But if there are approximately 40 devices on the local network, the problem begins to appear within a few hours after the reboot - the number of devices that are displayed as offline in IHost grows with every hour of operation. These same devices are perfectly controlled via the cloud. Rebooting your router every 3 hours is not normal.

@arcssua You might see a change if you reboot your rooter, but it is not solving the problem. At best what is happening is that you force the iHost to refresh its session with the router which might refresh the status it has for each device. The problem is not there - as you pointed out, you can perfectly control all your devices via the cloud (using web or eWeLink app) and the status of the devices are reported to the cloud through exactly that same router!! The point being - the problem is not at the router… So - let us go back to where the problem is - in the integration between the eWeLink add-on on the iHost and the local network, which is not being updated efficiently, probably due to the slow-down caused by the eWeLink add-on logging issue…

I’m not saying the problem is with the router. A TEMPORARY solution is to reboot the router.

Disabling the WMM and WMM APSD functions in the router interface completely solved the problem - within 24 hours, not a single device was offline. XIAOMI MI-3 router with Padavan firmware. These are functions that improve multimedia performance and an energy saving function. Try it on your routers. But disabling these functions is not normal and we need to look for solutions through eWeLink Smart Home optimization.

Hi, Pierred. EWeLink Smart Home add-on v1.3.3 was released. You can update and see if the problem solved. If not, please download the add-on log and send it via feedback. In iHost v1.10.0, download the log should not be a problem. We are looking forward to your feedback. Again, sorry for the inconvenience.

Thank you for the update. I am away on business at the moment but will install and test as soon as possible.

Pierre Durandt

I have an update - and it is good news. Installed iHost 1.10 and eWeLink add-on 1.3.3 this morning. Commands to control devices are now executing very fast and I do not get the “Unable to Control” messages anymore. I enabled a smart scene, and it seems to be working very well. I will do more testing and monitoring over the next days, but so far it is looking very good. Thank you eWeLink team!

1 Like