IHost and eWelink devices not working anymore


I have a strange thing with my iHost v1.9.1.
I have 14 wifi Sonoff switches with LAN control enabled and all of them was working fine until a few days.
On my 14 switches, only 3 at this day are working with iHost. I can control all of them with ewelink app but no more with iHost exept 3.
And it worked fine only a few days before. That´s incomprehensible !
Have you got any idea ?

1 Like

Sorry for your inconvenience. Can you download the system log and add-on log? So we can pinpoint the problem and fix it ASAP.

How to send you the log files ?

Download it and send it via feedback in the setting page.

Please download the add-on log and system log via feedback in the setting page. We’ll check it ASAP. Thank you.

It’s done. Thanks

Hi - refer to my post on this topic. Your problem seems similar, and it seems that it is connected to too much data being logged, leading to slow-down of the eWeLink adapter on the iHost. Apparently we can expect an update to the eWeLink adapter in September sometime, with the logging optimised. Hope to hear confirmation from support soon…

Read through this post: Failure to control eWelink devices on iHost

Thanks for your message. I hope an update will be available pretty soon because iHost is unusable for now…

Hello, the devices that you claimed to be uncontrollable. Are they all offline? Or just control it and always return with ‘Failed to control’ error?

Hello. The devices i cannot control are all on line. When i click on/off on anyone i can see the icon turn on or off but the switches don´t switch. I hope you know what i mean ?

From the log, some of your devices are unreachable in you LAN, so result in the control failure.
Here are the device id and corresponding ip from the log. Can you try to ping these ip from your computer and tell me what happen? PS: device id can be found in your eWeLink app setting page.


From your post, you said that these devices are perfectly fine in eWeLink app. Can you confirm they are all in LAN mode? If not, they might be controled by cloud and not LAN.

Or you can submit your eWeLink app log, we will check it to confirm the control mode of your devices.


All the devices are in LAN mode enabled. I can ping all with my computer with these results :

Packets : Send = 4, Received = 4, Lost = 0

As i said in my first post, all the devices worked fine before. I did not change anything in the configuration and one day, i was not able to control most of my devices with iHost.
If you want the ewelink app log file, where can i find it ?

I just reset my Wifi mesh system and everything is good now.

I don’t understand why just only a few devices worked but now all works fine.

It’s a thing you can communicate to people who have this problem, try to reset your router before to reach farther.

Anyway, thanks for your support !


My personal guess is that it may be related to the mDNS cache of the router - at present, we have also encountered the problem that the MATTER device is slow or even not corresponding after working for a period of time, and the problem located at present is the mNDS part. Restart the router, clear this part of the cache, and it can work smoothly - after working for a period of time, the router’s mDNS function began to respond slowly or even no response

However, other applications that do not require the use of mDNS capabilities are completely normal, at this time you will find that the router has no delay on you to watch videos, play games, and even control the device through the cloud through TCP commands, which has no delay at all. Only the functions within the LAN that require mDNS to obtain device status are affected.

Ok. So to prevent this matter again, i programmed a automatic reset of my router once a week during the night.
Thanks again for your support.

I have the same problem, i thought it’s from the mesh routers cause it’s 5g

Hello. I have 2 different wifi network. The first at 2,4GHz and the second at 5GHz with 2 different names. So, all my devices can connect to the 2,4GHz.

Was your problem solved permanently.?
Or it happened again?