Ihost won't connect with ewelink account

Hi. I’ve connected ihost to my router and I was able to connect to it via ihost.home but when trying to link it with my ewelink account it says ‘incorrect account or password’ eventhough i know it is correct… any ideas?

Forgot to mention that when I press ‘link’ it shows the following before I can go on to inserting my credentials: ‘Failed to respond try again later’

hi, what’s the firmware version? please go to system settings to check if there’s an update.

Please make sure that you select the correct country or region. If you select the wrong country, you may connect to the wrong server and fail to match the account. If you’re sure you’ve got the right country, check again to see if there’s an Internet problem. If that’s all right - maybe you just got the wrong password…

Finally, please check your firmware version - if it is earlier than 1.4.1, try use your account and pw to log in to the binding; If the version is 1.4.1, you can try to use the eWeLink App to scan the QR code on the web page to bind.

Ich habe gleiche problem,und kein Lösung

Hat einer Lösung???

no, I still cannot connect

Ich warte noch paar Tage, dann schicke ich das zurück.

Maybe it be the SD card reader. I could only connect some of my devices and now none because it forgets the SD card exists. Means the EWeLink Docker doesn’t run. Didn’t realise what on earth was going on but this seems like it. Not once did it ever say that the problem it was having connecting wifi devices related to the SD Card.

Have put the SD card from my iHost into a Raspberry Pi running Linux. It sees it and has a folder structure, although seems empty. Need to interrogate it further for invisible files but it works here. Have tried 3 SD cards. Have tried using the USB port and an external SD card reader (nothing happened). Have tried a USB memory stick (hung).

In my opinion, this touiches three major problems:

  1. There seems to be an issue with some tf cards. Newer ist not always better. But smaller seems to be. If you have, try a 32GB card. This is a tip from @Rossi14 in a different thread which helped me. My (new) SanDisk Ultra 128GB renders my iHost practically useless. My new 128GB Extreme works, so does an older 32GB (class 10). There is supposed to be an update in a few days.

  2. Lack of feedback. Users don’t know, what the machine is doing at the moment, what the progress is or if it is stuck. More messages or means of feedback would help.

  3. No possibility to backup the iHost. When problems occur, you are likely to lose all configuration and maybe even dockkers. This is one thing that worries me, while playing with the iHost. Even the Home Assistant container (/armv7-homeassistant) has no means to restore a backup. Nome Assistant is third party, of course. But I would imagine there are quite a few people out there who would like to use it with a container like that.
    Note: iobroker does have a way of restoring backups from an external source, which is good for me, because I use iobroker. But one reason I ordered the iHost was to experiment and learn. Also I think that Sonoff is on a good track and with a few improvements, this box could be neat.

1 Like

I found files. Admittedly hardly any. Think it has lost my dockers, but I expect when the TF/SD card is working properly you could backup the SD card as a disk image on a Linux machine.

Not figured out what format the disk is yet, as I don’t know Linux. Have searched for the equivalent of a Disk Utility but no luck so far. I know it’s not a Windows 11 file type as I’ve tried there before.

I did try a 32Gb but it didn’t even see it at all, so I’m back to a 64Gb where it atleast know there is a card, even if nothing on it works.

Trying to think where I may also have another. All the ones so far have been high speed as I took them from action cameras. It might not like high speed cards.

My current failure followed trying to install docker compose. Don’t see how you’re supposed to install a dockerised home assistant without it, but suspect I was duplicating an invisible thing.

I have version 1.4.1 tried both methods and it doesnt work… how do I check if there is i ternet connection on ihost? Got ip address from the router ok.

Leute ich habe kein Problem mit docker,sd karte . Sehen sie Bilder bei mir ist Problem ewelink app mit ihost verbinden. Aus internet kann ich Zugreifen.

Da kann man nicht viel falsch machen,strom und lan rein, alles im gleichen Netz und daten eingeben,das was. Wie man sieht nicht mal qr code gibt nicht.

Den ungültigen QR-Code hatte ich auch mal, aber bei mir ging es mit der manuellen Anmeldung. Blöde Frage: Hast Du einen Router (z.B. Unifi), wo Länderblockierungen eingestellt sind? China…?

Obwohl, ne - er meldet ja “incorrect account or password”. Heißt: Er macht eine Validierung.
Andere Option: Das Passwort ist - aus deren Sicht - tatächlich falsch? Ungewöhnliche Sonderzeichen? Mal kurz in der App ändern und dann ausprobieren?

Nein ich habe Fritz Box, ich habe zurück gesetzt paar mal hat nicht geholfen. Ich habe keine Idee mehr

Habe ich Passwort u dann noch ein Account gemacht, egal geht nicht. Wenn man könnte andere Firmware Update, wie man sieht ich bin nicht einzige mit dem Problem. Ich bin dankbar für jede Idee, ich habe fast Hammer genommen und klein gemacht.

Hat jemand eine Idee, kann man Firmware über USB oder online machen? Ich habe keine Idee mehr, ohne Update geht nicht.

Hallo, es könnte ein Problem mit Ihrem iHost geben, in diesem Fall empfehlen wir, den SONOFF-Support zu kontaktieren, um einen Ersatz zu erhalten.

Hi, There might be some problem with the iHost you got, in this case we recommend contacting SONOFF support for a replacement.

Vielen Dank

Gesendet von Outlook für Android