Manual scene enabling other auto scenes doesn't work

I have setup a manual scene (“tap to perform” trigger) which enables a set of other automatic scenes. When I tap on the manual scene I got “success” flash notification, the automatic scenes are shown as active but they don’t work (e.g. they don’t perform the action when it’s the time specified in their trigger). Sometimes it helps if I disable and enable the automatic scenes manually. Since it is a set of more than 10 automatic scenes it is not convenient to disable and enable them one by one manually. Could you please correct this behaviour and ensure that enabling automatic scenes works reliably?

when you enable the scenes by manual scene, do you mean all of the automatic scenes don’t work? or just some of them?
how long is it between the specified time and the time you tap manual scene to enable them?
(I tried to create a manual scene to enable an auto-scene which is several minutes later and it does work.)

Hi, I think it doesn’t matter how many scenes don’t work.They are supposed to (and must) work all, not just some of them.
Anyway, to answer your question: the first automatic scene didn’t work and it was expected to be triggered approx. 15 minutes after pushing the button for manual scene.Therefore I disabled and enabled all the automatic scenes manually and now I can’t say if the rest would work or not. BTW logging events like enabling and disabling automatic scenes and logging manual scenes trigerring is missing in the app. This would help a lot.

To describe my use case: at approx. 19:00 yesterday (2.2.) I pushed the manual scene “Going to the Cottage” which enabled a set of automatic scenes. One of them is “Cottage Workday 19:15 Heating ON” which switches on the heating. But it didn’t happen and I had to switch the heating on manually at 22:12:00. See all the available logs and settings.

thank you for the details.
Please try again, when the auto time is coming, tap the manual scene to see if the auto-scenes execute.
If not, please try to delete the manual scene and create a new one.

Hi, I did several tests and got different results. Waiting for the time coming and tapping the manual scene didn’t help. The automatic scenes were enabled but didn’t execute. Therefore, I deleted the manual scene and created a new one with exactly the same setup. It was working for a couple of days after creation but then it stopped working again. I think deleting a manual scene and creating a new one each and every time it stops working is not a good and convenient solution, I am sorry.

BTW, I realized the same behavior of the scenes that are enabled/disabled by another auto-scene. Simply put, enabling and disabling scenes by the system (be it tapping the manual scene or execution of an auto-scene) is not reliable. What comes as a surprise to me is the fact that manual disabling and enabling auto-scenes (by tapping on the blue switch in the app) works if the conditions are met at the time of tapping. If these conditions are met later then no one knows if the particular auto-scene executes or not.

I’ve forward your case to our Dev&Test team, they will perform some tests and checks.
will keep you updated. by the way, seems your auto-scenes control a heater, can you send me the model number of that heater?

Hi, thank you. I think the heater model and its number is irrelevant since I use Sonoff 5V/7-32V WiFi relay to switch heating system on and off based on temperature (Sonoff Temperature and Humidity sensor SNZB-02 connected via Sonoff ZigBee bridge) and the time interval. Unfortunately I was not able to get the automatic scenes working in a particular time interval (effective period). The Sonoff relay has the limitation of 8 timers so I was trying to solve this by disabling/enabling scenes which doesn’t work either. I reported my issues in other threads of this forum. Unfortunately I am vendor-locked to Sonoff with the ZigBee bridge but if this doesn’t get solved soon I will replace it with a bridge of another vendor and get rid of ewelink at all, I am sorry.

I encounter a similar problem. When you enable a scène from out an other scène the triggers are not rechecked. In case you manual enable the scène the triggers are checked and the scène runs. Please change the code that a status e.g. “when door is open” is checked when you enable a scène.