Manual scene enabling other auto scenes doesn't work

I have setup a manual scene (“tap to perform” trigger) which enables a set of other automatic scenes. When I tap on the manual scene I got “success” flash notification, the automatic scenes are shown as active but they don’t work (e.g. they don’t perform the action when it’s the time specified in their trigger). Sometimes it helps if I disable and enable the automatic scenes manually. Since it is a set of more than 10 automatic scenes it is not convenient to disable and enable them one by one manually. Could you please correct this behaviour and ensure that enabling automatic scenes works reliably?
Thx

1 Like

when you enable the scenes by manual scene, do you mean all of the automatic scenes don’t work? or just some of them?
how long is it between the specified time and the time you tap manual scene to enable them?
(I tried to create a manual scene to enable an auto-scene which is several minutes later and it does work.)

Hi, I think it doesn’t matter how many scenes don’t work.They are supposed to (and must) work all, not just some of them.
Anyway, to answer your question: the first automatic scene didn’t work and it was expected to be triggered approx. 15 minutes after pushing the button for manual scene.Therefore I disabled and enabled all the automatic scenes manually and now I can’t say if the rest would work or not. BTW logging events like enabling and disabling automatic scenes and logging manual scenes trigerring is missing in the app. This would help a lot.

To describe my use case: at approx. 19:00 yesterday (2.2.) I pushed the manual scene “Going to the Cottage” which enabled a set of automatic scenes. One of them is “Cottage Workday 19:15 Heating ON” which switches on the heating. But it didn’t happen and I had to switch the heating on manually at 22:12:00. See all the available logs and settings.





thank you for the details.
Please try again, when the auto time is coming, tap the manual scene to see if the auto-scenes execute.
If not, please try to delete the manual scene and create a new one.

Hi, I did several tests and got different results. Waiting for the time coming and tapping the manual scene didn’t help. The automatic scenes were enabled but didn’t execute. Therefore, I deleted the manual scene and created a new one with exactly the same setup. It was working for a couple of days after creation but then it stopped working again. I think deleting a manual scene and creating a new one each and every time it stops working is not a good and convenient solution, I am sorry.

BTW, I realized the same behavior of the scenes that are enabled/disabled by another auto-scene. Simply put, enabling and disabling scenes by the system (be it tapping the manual scene or execution of an auto-scene) is not reliable. What comes as a surprise to me is the fact that manual disabling and enabling auto-scenes (by tapping on the blue switch in the app) works if the conditions are met at the time of tapping. If these conditions are met later then no one knows if the particular auto-scene executes or not.

I’ve forward your case to our Dev&Test team, they will perform some tests and checks.
will keep you updated. by the way, seems your auto-scenes control a heater, can you send me the model number of that heater?

Hi, thank you. I think the heater model and its number is irrelevant since I use Sonoff 5V/7-32V WiFi relay to switch heating system on and off based on temperature (Sonoff Temperature and Humidity sensor SNZB-02 connected via Sonoff ZigBee bridge) and the time interval. Unfortunately I was not able to get the automatic scenes working in a particular time interval (effective period). The Sonoff relay has the limitation of 8 timers so I was trying to solve this by disabling/enabling scenes which doesn’t work either. I reported my issues in other threads of this forum. Unfortunately I am vendor-locked to Sonoff with the ZigBee bridge but if this doesn’t get solved soon I will replace it with a bridge of another vendor and get rid of ewelink at all, I am sorry.

I encounter a similar problem. When you enable a scène from out an other scène the triggers are not rechecked. In case you manual enable the scène the triggers are checked and the scène runs. Please change the code that a status e.g. “when door is open” is checked when you enable a scène.

1 Like

Do not spend any more time on this matter guys, this feature does not work period.

I think that manual enabling of autoscenes works. The problem is how these autoscenes get triggered after having been enabled. The triggering algorithm is implemented in a specific way which doesn’t correspond to our expectations. Anyway, as soon as you know how the triggering works then you can adjust your scenes according to it.

Had a similar problem, what I found was when I setup my schenes I didn’t select every day - it defaults to “once”, see my screehots:




I think I’ve observed similar behavior, where a manual scene enabling an auto scene doesn’t get triggered by the condition. I was theorizing that because a condition was already met at the time of enabling, it ignored it and didn’t trigger, versus the condition actively changing after the auto scene was enabled.

When you say “as soon as you know how the triggering works then you can adjust your scenes” what did you learn??? How is the triggering algorithm setup?

Hi, you got it right. I had a scene with the trigger of the temperature below 16 degrees and I enabled this scene with another manual scene. The automatic scene didn’t get triggered after enabling even if the temperature was below 16. This is what I got from ewelink support: “We apologize for the inconvenience, but we wanted to let you know that the scene you have enabled hasn’t been executed due to the current temperature being below the required threshold of 16 degrees. We understand that it can be frustrating to wait for the right conditions to trigger the scene, but please know that this threshold has been put in place to ensure the safety and effectiveness of the scene.
Please keep in mind that even if the temperature remains below 16 degrees, the scene will not be executed until it reaches above 16 degrees and then drops below again. And this is determined by the firmware. We want to ensure that the scene performs as intended and provides you with the best possible experience.
If you have any questions or concerns about this, please don’t hesitate to reach out to our support team. We’re always here to help and want to ensure that you have the best experience with our service”. Hope it explains the triggering algorithm well.

Ha, so it doesn’t really help very much, just confirms that it is required to change from one status to another (cross the temperature threshold).

If it helps your use case, I made a work around, but it requires the use of another relay.

This was my initial setup…
I have two manual scenes called “pool mode” and “spa mode”.
I have auto scenes for temperature control:
“pool is cold” if temp is <=85, turn relay off
“pool is hot” if temp is >=86, turn relay on
“spa is cold” if temp is <=100, turn relay off
“spa is hot” if temp is >=101, turn relay on
Manual scene “pool mode” enables auto scene “pool is cold” and “pool is hot” and disables “spa is cold” and “spa is hot”. The inverse is true for manual scene “spa mode”.
If manual scene “pool mode” is run, and after some time, the temperature increases above 86, auto scene “pool is hot” will trigger and turn on its relay (as expected, that part is good). If I then manually run “spa mode”, the auto scene “spa is cold” does not trigger and the relay is not turned off (even though the temperature is well below the 100 setpoint). Keep in mind that auto scenes “pool is cold” and “pool is hot” are disabled when I enter “spa mode” so I don’t think that’s conflicting.

But as we’ve both encountered, an auto scene won’t recheck if enabled by another scene (or an effective period time window).

The solution…
“pool is cold” if temp is <=85 & relay1 is on, turn relay3 off
“pool is hot” if temp is >=86 & relay1 is on, turn relay3 on
“spa is cold” if temp is <=100 & relay2 is on, turn relay3 off
“spa is hot” if temp is >=101 & relay2 is on, turn relay3 on

I modified manual scenes “pool mode” and “spa mode” to turn on these new relays 1 and 2 respectively (and turn them off respectively when switching from one mode to the other). I coincidentally use those relays to control valves on my pool, so they are real and do serve a purpose associated with pool and spa mode. Depending on your use case, you might need to invest in an extra couple ewelink/sonoff devices to help with your conditional statements, and then have those relays be triggered by time or a manual scene. But this works, this does not require the temperature to travel past the setpoint to trigger.

Cue applause!

I think I failed to mention that the new autoscenes should be on 24/7, no longer being enabled/disabled by other scenes. They shouldn’t ever conflict with each other because of the extra relay condition.