Enable/disable scenes from another scene

I know this have been discussed before, but I couldn’t find an exact explanation of how it’s supposed to work!

We have the option to make an action that enables/disables a scene.
But that’s clearly not what’s happening when using this function!

When I try to disable a running scene, it will be disabled (the button on the graphic sets to off).
But when the conditions for that scene is met again, the scene will trigger anyway! Even though it’s set to disabled!

Disabling the scene manually doesn’t behave like that.
Why is it different?

Is this the intended way it should work?
I can’t see many situations this will be useful!

I haven’t tested, but does it make a difference if the enable/disable is triggered from a manual or automatic scene?

I need an option that can make a scene absolutely inactive, meaning it can not be triggered by anything than a command to activate it again.
Is that possible?

Please explain this enable/disable logic. I just don’t get it!

Thanks.

BR

Ricky, DK

which platform are you using for scenes? iHost/NSPanel/eWeLink App/eWeLink Web?

I have a very simple setup right now.
2 pcs Sonoff TRVZB’s, a SNZB-02D for measuring room temperature and a ZB Bridge-P.
I use the eWeLink app and/or the web interface for setting up scenes, monitoring and so on.

Ricky

hi,
please attach some screenshot of your scene settings

I think I found a workaround by following this great idea with an extra relay:

I test it right now, but it should work.
I have changed my scenes now, so I can’t show you how it was.

Still I think it’s unnecessarily difficult to make such simple things work.

Basically what I want to do is this:
All room temperatures are measured by the SNZB-02D, since I can’t trust the TRVSB’s reading. You can’t measure a room temperature right next to a heat source!

I want 23 degrees celcius constant temperature in the room.
BUT at night I want to trigger a button (from the app or when I buy one, a physical button) and have 19 degrees celcius until 5 o’clock in the morning (7 o’clock in the weekends).

So I made these scenes:
Room temp below 23 deg → Heat TRV to 28 deg.
Room temp 23-24 deg → “Heat” TRV to 18 deg.
Room temp over 24 deg → Turn off TRV

When I trigger the “night button” to get 19 degrees, I need to make sure that these scenes will not trigger and overrule the 19 degrees scene.
This apparently doesn’t work!

Are there any way to do this without an extra relay, or using Home Assistant?

BR Ricky