eWeLink Add-On to Home Assistant not working

I’m just starting to try to get eWeLink Smart Home integration to work within my Home Assistant. I’ve gone through what steps I can find to install it, which it is installed but it shows all my devices (which all I have right now are just Sonoff outlet smart plugs) are not supported.

One step that confuses me is the Long-Lived Access Token. I’ve got that token copied off, but on the eWeLink Smart Home Integration, there is no Options entry to put in the auth code. The screen shows the Network web interface setup but no Options area. I don’t know if that’s why it’s showing my devices as not supported.

I do have the Sonoff-Lan installed and it shows the devices on it, and my main dashboard does show them on that also. But it’s just the eWeLink Smart Home screen I can’t get to work.

Can any give me any help or possibly let me know what I’m doing wrong?

Do you following the tutorial here eWeLink guys posted? UPDATED eWeLink add-on V1.3.3 for Home Assistant

They only support add-on way, not integration of HA.

I accidently said Integration, but I did do it through the Add-Ons. When I’ve tried that link with the git URL listed in it, I get the following error:
I had found one other link that used a slightly different URL as: GitHub - CoolKit-Technologies/ha-addon
This one would work and I was able to add this to my Home Assistant but I get the following when I open my Home Assistant Smart Home:

This is what I can’t get to work. My 4 devices listed are the Sonoff S40 WiFi Smart Plugs.

The message is clear that the S40 Smart Plugs are not currently supported. I believe it is on the list of items eWeLink will be adding in the future releases of the Add-on. I would check the end of every month to see if any new updates have been posted.

I can tell you that the S31 Smart Plugs do work with the current Add-on version. I have 8 up and running.

Thank you. I had a friend that had been using Home Assistant for awhile and he had his working fine, but after you said that, I re-asked him what models he had and he said they were the S31TPB plugs. And he had just received the same ones I got and had the same issue. So that explains that issues.

But would you know why I can’t get the Add-on installed using the URL: https://github.com/CoolKit-Technologies/Home Assistant-addon.git
I don’t know if there is any difference between using that URL or the one that I can get to work at: GitHub - CoolKit-Technologies/ha-addon

https://github.com/CoolKit-Technologies/Home Assistant-addon.git is the link for github page, GitHub - CoolKit-Technologies/ha-addon is the right link for repository.

Have edit the tutorial to make them the same, thanks for the feedback.

S40 series implement request received, will make it supported later, please stay tuned.

Thanks All for the support and help.

Hi, today I installed eWelink HA Addon in my Home Assistant (version 1.4.3). In the log I have a lot of errors like these:
2023-02-10T15:29:17.157Z [ERROR] getDataSync: disabled.json → 10015cd151 no data
2023-02-10T15:29:17.159Z [ERROR] getDataSync: disabled.json → 10015cc93d no data
2023-02-10T15:29:17.161Z [ERROR] getDataSync: disabled.json → 100156adce no data
2023-02-10T15:29:17.165Z [ERROR] getDataSync: diy.json → no data
2023-02-10T15:29:19.678Z [ERROR] getDataSync: disabled.json → 10015cd151 no data
2023-02-10T15:29:19.681Z [ERROR] getDataSync: disabled.json → 10015cc93d no data
2023-02-10T15:29:19.684Z [ERROR] getDataSync: disabled.json → 100156adce no data
2023-02-10T15:29:22.051Z [ERROR] getDataSync: diy.json → no data
2023-02-10T15:29:27.387Z [ERROR] getDataSync: diy.json → no data

I’have 3 NS Panel EU seen as switches. 4 switches for each NS Panel, I don’t know why.
I hope you will add the possibility to see also the internal temperature soon and also to set the thermostat setpoint.
Thanks for your help


2023-10-13T11:18:18.439Z [INFO] server is running at 3000
2023-10-13T11:18:18.443Z [INFO] Finding local eWeLink devices…
2023-10-13T11:18:18.446Z [ERROR] getDataSync: user.json → login no data
2023-10-13T11:18:18.447Z [INFO] initCkApi loginParams: null
2023-10-13T11:18:18.447Z [ERROR] getDataSync: user.json → user,apikey no data
2023-10-13T11:18:18.448Z [ERROR] getDataSync: user.json → at no data
2023-10-13T11:18:18.448Z [ERROR] getDataSync: user.json → region no data
2023-10-13T11:18:18.449Z [INFO] Start init lib-ha…
2023-10-13T11:18:18.458Z [ERROR] getDataSync: user.json → user no data
2023-10-13T11:18:18.473Z [INFO] WebSocket2Ha connecting…
2023-10-13T11:18:18.477Z [ERROR] getDataSync: user.json → no data
2023-10-13T11:18:18.481Z [INFO] WebSocket2Ha connect success
2023-10-13T11:18:18.521Z [INFO] Found LAN enhanced plug
2023-10-13T11:18:18.523Z [ERROR] getDataSync: disabled.json → 1000ae6670 no data
2023-10-13T11:18:18.524Z [ERROR] getDataSync: rate.json → 1000ae6670 no data
2023-10-13T11:18:18.800Z [INFO] Found LAN enhanced plug
2023-10-13T11:18:18.801Z [ERROR] getDataSync: disabled.json → 1000cd9439 no data
2023-10-13T11:18:18.802Z [ERROR] getDataSync: rate.json → 1000cd9439 no data
2023-10-13T11:18:19.023Z [INFO] Found LAN enhanced plug
2023-10-13T11:18:19.024Z [ERROR] getDataSync: disabled.json → 1000ae6670 no data
2023-10-13T11:18:19.301Z [INFO] Found LAN enhanced plug
2023-10-13T11:18:19.302Z [ERROR] getDataSync: disabled.json → 1000cd9439 no data
2023-10-13T11:18:19.521Z [INFO] Found LAN enhanced plug
2023-10-13T11:18:19.522Z [ERROR] getDataSync: disabled.json → 1000ae6670 no data
2023-10-13T11:18:19.651Z [INFO] Found LAN enhanced plug
2023-10-13T11:18:19.652Z [ERROR] getDataSync: disabled.json → 1000a94fda no data
2023-10-13T11:18:19.654Z [ERROR] getDataSync: rate.json → 1000a94fda no data
2023-10-13T11:18:19.800Z [INFO] Found LAN enhanced plug
2023-10-13T11:18:19.801Z [ERROR] getDataSync: disabled.json → 1000cd9439 no data

It started working normally again for no reason. That’s strange, right!

I had it working till end of March’24 when it’s not loaded in Home Assistant on RP4. Then I tried to re-install and I got this error. I tried to remove and add the repository again but has no luck installing it anymore. Any clue??

below is the error

Failed to install add-on

The command ‘/bin/sh -c npm install --production --save-exact’ returned a non-zero code: 1