How to add smart plug to the HA dashboard?

Hello, I’ve successfully added my 1st home automation, the eWeLink WL-SC01 smart plug.
I’ve added the smart plug to Home Assistant, but the smart plug only seemed to add in when I log into the eWeLink Smart Home website.
If I try to add the smart plug to the HA Dashboard, the entity I am offered is eWeLink Smart Home Update, which is not an On/Off switch, rather an unnecessary eWeLink website update?

What is the smart plug linked to? To eWeLink or to the Home Assistant? Your description is a bit chaotic.

1 Like

Sorry, I’m a bit unclear with my 1st home automation.
I had to setup the smart plug WL-SC01 by logging into the eWeLink app account.

Once that was working, I tried to put the smart plug on my preferred Home Assistant.

I added the smart plug, but nothing connected until in Home Assistant I logged into the eWeLink account.

OK, now I understand. You have installed the eWeLink add-on in HA. The socket is connected to the eWeLink cloud (app), right? Is it a WiFi device?

1 Like

The eWeLink WL-SC01 smart plug has a Wi-Fi connection to my Wi-Fi AP.
The Wi-Fi AP has an Ethernet cable to the LAN and WAN.

The WL-SC01 socket is designed for the Tuya platform. It’s not a Sonoff (eWeLink). I understand that you have connected the device to the eWeLink cloud and that you can fully control it from the app and/or eWeLink Web, yes?

1 Like

Yes, those were the instructions, to connect to eWeLink.

Really? Tuya device’s manual instructed you to connect to eWeLink?
You didn’t answer the most important question: Can you fully control the device from eWeLink app/cloud?

1 Like

Sorry if I missed a question. Yes, the smart plug is controlled from eWeLink app/cloud.

Let’s start with the fact that the so-called official eWeLink integration is outdated and has not been updated for many months. I have asked eWeLink staff several times on this forum what is going to happen with it. Well, nothing will happen, because they do not have it in their plans. As for the need to log in to the eWeLink account multiple times, you apparently bypassed getting a longlived-token when setting up the integration or something went wrong with it. But let’s leave that integration out of focus. There is a better solution.
First, delete the eWeLink integration remembering to remove all devices and automations associated with it beforehand. Then, using HACS, install the Sonoff LAN integration. It’s a Home Assistant custom component for controlling Sonoff devices with eWeLink (original) firmware over LAN and/or Cloud. I have been using it successfully for many weeks. Ask if anything is unclear.

  1. Uninstalled the eWeLink Add-on.
  2. HACS Integrations doesn’t show the ‘Plus’? I opened Integrations | HACS in Incognito mode to ensure no browser cache, but same issue. (I was unaware, but perhaps I’m meant to install HACS into HA?)
  3. I downloaded and extracted the sonoff directory from the latest release, however I’m unable to find HA’s custom_components directory in the HA config directory?
    Using HA Terminal, the commands aren’t BASH, so I’m stuck navigating or listing HA’s directories?
  4. Installed HACS into HA, however error at Sign in to GitHub · GitHub code to authorise HACS. Github confirms via email a third-party OAuth application has been added to my account. Unfortunately, HA won’t update to Success!
    I refreshed the HA browser page, but had to re-authorise HACS with Github. Issue remains where HA won’t update?

Please, read this carefully. You need a Github account to work with HACS. You obviously did something (very) wrong, because normally it’s a pretty straightforward process. You need HACS to install community components.
One thing more. Your HA instance cannot be a docker installation on an iHost.

1 Like

I run HA as a VM on the Qemu hypervisor.
I do have a Github account, so maybe the VM HA is too complicated for Github and HACS to communicate?

I read HACS and used the bash command to download.
This video was good up to the issue at 4:40.

Did you install HACS afterwards?

1 Like

TLDR; I can’t reach the last image on the HACS guide.

I tried to install by adding the integration, approving the 5 permissions, then pasting the key to authorise HACS in Github, which succeeds, but HA won’t update to accept HACS.

Before HACS can show up in the list you need to clear your browser cache. Then go to the “Settings” in the Home Assistant UI. Click “Devices & Services” and the “Integrations” tab in the Home Assistant UI. Click +ADD INTEGRATION. It should look like this:

Select HACS and go for it. The last step is to restart.

1 Like

Yes, I did clear the cache then followed all the steps through ADD INTEGRATION, but HACS won’t add to Devices & Services.

What is your HA installation type? Go to Settings → About. Make a screenshot and show it here.

1 Like

Core: 2024.5.0
Frontend: 20240501.0
Operating System: 12.2
Supervisor: 2024.04.4

So what specifically is going on?