4CHPROR3 reacts to unpaired buttons

Hello everyone,

I have been using Sonoff products for a long time now but I came across an issue I have never encountered before today. Our newly bought batch of 4CHPROR3 switches is acting weird. They came with the latest 3.7.6 firmware installed. After they are initialized I can activate channels using unpaired buttons from different brand switch. The whole behavior is very weird because the different brand switch will toggle all 4 channels.

We have few more 4chpror3s and different sonoff products but none react to these switches only 4chpror3s with the latest firmware. These other brand switches also operate at 433MHz but slightly shifted so they never worked for us with any other device and we tried with older 4chpror3s we had to pair these old switches to them with no luck. Any idea what might be causing this behavior? Any way to roll back to different firmware version?

We did some more investigation and here are some findings.
Older 4CHPROR3 devices that run the latest firmware do not have this issue.
Here is video with problematic device and an older device:

Therefore problem looks hardware related to me. We bought 3 devices that came with pre loaded latest 3.7.6. firmware that have this same issue. I would guess something was wrong changed in the production?
Any suggestions how to fix this?

Are you using the same remote for the new and old versions?

I encountered another symptom in the context of a MOES remote where, for some unexplained reason, three buttons initialized whenever only one of them was pressed. Buttons 1,3,4 behaved as one, as a result of which the devices became stupid when they received three activations at the same time.

The only thing left for you is to create an official ticket and possibly return the purchased versions as defective.

Yes as shown on the video the exact same remote is used.
This remote should NOT work at all with these sonoff devices.

So it looks like a bug in FW or something more serious in the hardware, as you thought…

Do you have another remote to test?

It seems that either there is something wrongly set in the FW and Sonoff reacts to anything, or it is set to specific settings and by pure coincidence your remote transmits the same.

What would I do in such a situation…

Reset to factory settings.
Reprogram the channels so that the settings are overwritten.
Filing a complaint via a support ticket and requesting a replacement/refund of devices.

What do you mean that the remote should not work with sonoff?
Is there 433Mhz with a fixed code and proper modulation?
Or does the remote generate interference in the air and Sonoff becomes stupid as a result? Because it would mean an extreme defect of the device…

Did you try to clear RF codes? Long press the channel switch button for 5s until the LED indicator turns red and quickly flashes twice. Release, then short press the
button to be cleared on the remote control. If the LED indicator turns red and
flashes once, it indicates that the code is cleared. Do this for all channels. Pair again. If the problem is not gone, repeat clearing and try with different remote that is compatible with Sonoff fixed-code devices.

I have tried to remove RF paired devices. It did not help at all.
These problematic 4chpror3s react to few of these other buttons basically as soon as they get any power. Even after full device reset.
As I mentioned other sonoff devices (even some older 4chpror3s) do not recognize and cannot be paired to these buttons.

I am experiencing exactly this same issue with a new 4CHPRO R3 unit that I recently bought. In my case is a remote from a nearby garage door the one causing the interfeerence. Hence all my neighbours are accidentally switching on and off all 4 channels in my 4CHPRO R3. Another old 4CHPRO R3 unit (motherboard v1.0) that is located at the same spot as the new one does NOT show this behavior and it is running same FW version 3.7.6. So I agree that it seems a HW issue with the latest v1.1 motherboard.

Any solutions or workarounds? Any option to disable the RF module? This is very very frustrating.

I tried cleaning the RF signal from the channels but that does not seem to be the solution. The interference keeps happening. It is like ‘hardcoded’ into the device.

If you have an SDR radio and a bit of time, you can look at the exact codes that Sonoff responds to…

This won’t fix the problem in any way, of course, but it will give a full picture of the culprit. In my opinion, such a device should be classified as inoperable and require replacement by the manufacturer or a refund.

It is absurd for the device to behave like this in 2023/24…

I was talking about this with Sonoff support as well and they offered to send me replacement units. I think I will take them up on that offer.

They mentioned that RF function can be disabled. You have to cut the RF antenna.

In my logs when the problematic button is pressed it shows that all channels were turned on.
These logs correspond to the video I posted:

It should not be possible to pair RF function to that option. Additionally its flagged as device local button - as if I was pressing the buttons on the 4chpror3 that control the channels. But even with those buttons it should not be possible to trigger all the channels at once.

1 Like

It looks like a serious bug in the device… but does it affect a small group of devices or an entire large production series…

Anyone who has this problem should file a complaint and request a replacement. Because a solution like cut a path on the PCB or unsolder some element is an absurd extreme in the case of a new product. Sonoff sells a defective product that should not be on the market.

1 Like

I checked my problematic boards they are rev1.1. I could see some changes on the pcb when comparing with v1 but to mine untrained non electrical engineer eye nothing looked “logic” related.
I am going to report later when replacements arrive.

1 Like

I have the exact same issue. Has anyone made any progress on this? Whilst it does seem ridiculous, I’m not adverse to cutting the RF antenna as I’m never going to use it and seems quicker / easier than wiring in a new device. Does anyone know exactly how to do this?

You can see the board in the picture.
Screenshot 2024-01-15 104551

The RF module is the one indicated by the screwdriver. The antenna is the coil. The antenna should be soldered or cut off (carefully) right at the board. An even better idea might be to solder out the resonator. The resonator is that silver piece just below the screwdriver tip. To do this, use a soldering iron and tin extractor. Everything should be done carefully and with the power supply disconnected. Better be safe than sorry.

1 Like

But do you agree that performing such an operation on a newly purchased device in order to obtain basic, stable functionality is absurd? :slight_smile:

Sure thing! That’s why I got rid of all my old, RF capable devices. Two of them had a nasty habit of switching on in the middle of the night. That drove my wife mad :slight_smile:

1 Like

Yeah - I actually tried to order the non-RF one but it took too long so got the RF enabled one instead
As a temporary measure I have implemented a faraday cage made out of silver foil - seems to allow my Wifi through and is blocking maybe 90% of interference - equally ridiculous to need to do!

1 Like

Its definitely absurd but we need RF functionality as well. We would have bought non pro version otherwise.

Ok, sure, I’m not saying that rf433 is bad in itself, but the way it is implemented here is a joke. :slight_smile: