4CHPROR3 keeps on being triggered on by itself

Hello! Some my devices (Sonoff 4CHPROR3) keeps on being triggered on and sometimes off by itself! Reviewing the logs > it says device triggered (Device-Local Button triggered) but noone touched them. Thanks to assist!

Your problems are most likely due to the fact that the Sonoff 4CHPROR3 supports the remote controller with 433.92MHz frequency band. This frequency is not protected and there is significant scope for interference, both on frequency and on adjacent frequencies, as the band is far from free. It can therefore be considered that there are many other devices operating in the vicinity, including remote keyless entry systems. It can therefore be assumed that the signal from another device is received by 4CHPROR3 and interpreted as if it were a control signal. Remember that in this case it is a fixed-code signal. I know from my experience that fighting this is exceedingly difficult. Even if you could sniff 433, capturing a short transmission and determining its source is like mission impossible. In my area, the culprit was most likely the communication system used by the security of an office building, which affected one of the switches. So, I disconnected the RF module in the switch and the problem was solved.
Of course, there is no certainty that this applies to your case as well but check this lead.

1 Like

Thank you so much! Yes, my problem is in the RF-module. How exactly disconnect it? I removed the cover, but there is no separate module there. Thank you!

With 4CHPROR3 it’s not easy. The RF module is integrated to the board. Unless you are able to locate the chip and remove it, I suggest unsoldering the RF antenna. It’s a coil (spring) located at the edge. You can’t miss it. Or ask someone familiar with electronic circuity to do so. Best of luck :sunglasses:

Removing the antenna doesn’t solve the problem. But I found a simple solution - I also mechanically removed the 6.7458 MHz Crystal. Problem solved! :slight_smile: Thank you so much!


Could you please elaborate a bit more how you achieved this? I am also having the same issue. I will have to disable the RF module due to interferences with nearby garage doors

Also, I have two 4CHPRO R3s, one old (bought a couple years ago) and one new. This issue of RF interferences is only showing on the new one -motherboard v1.1- not the old one -motherboard v1.0- and both are located at the exact same place hence equally being exposed to nearby RF signals. But only the new one seems to be ‘sensible’ to them, the old one only reacts to its previously set Sonoff RF remote as expected.

If you do, you won’t be able to control your device with any RF remote.

Yes, this is the big downside of it :frowning: but I guess better than random signals activating my stuff… this issue is driving the RF feature completely useless.


How on earth did the company release such a defective product…?
It’s absurd that a product would go crazy as a result of random 433Mhz signals… Who designed it and allowed it to be sold, it’s absurd!

That’s why it is called PRO :stuck_out_tongue_winking_eye:

1 Like