Why can't I use a device state as both a trigger and an action in an auto scene

I don’t understand why I cannot select a device state for both a trigger and an action.

My use case:

I have a temp / humidity sensor in a room, as well as a fan controller.
I want to automatically set the fan to a certain speed, based off the current temp…
but I only want to do it if the light on the fan, is on. (basically using the fan as a rudimentary presence detection)

However - if I pre-populate the action with the fan state - I cannot see the fan in the triggers, and vice versa.

(and before anyone suggests the motion sensors - 1st of all I don’t see them as neccessary, 2nd of all - the Zigbee PIR sensors I am testing in other rooms are absolute battery hogs - to the point of making them useless… plus the “no motion” detection doesnt have an option for “no motion for x time” which also makes them super annoying to use)

In case the trigger and action makes some conflict, so one device can only be set to a trigger or action.

It’s a better way to using a occupy sensor as a trigger. I think there will be a new device release lately from Sonoff.

Thats frustrating - I am sure you could run validation against those scenarios in your code…

its frustratingt that I have to spend more money when simply using the light portion of the fan control to enable and disable temperature control would work

If you are using a TH10, this kind of automation is done DIRECTLY on the device in the app
I have a TH10 with the thermometer in a freezer and a siren plugged in its 120v output.
When temp > -10 degree it power on the siren and send notification
when tem < -10 power off the siren.

THis is set on the device not in scenes

Hi there,

I am not doing this on the TH10 - I have the iFan - and I have a temp and humidity sensor… I want to automatically control the fan - but only when the light is on. I would think this would be easy to do in 1 scene - but it appears not

the state information is there, its frustrating that the software limits me using it though.

Do you have one of the devices that runs Node Red already (iHost and NSPanel-Pro I think from them or an always on computer/Raspberry-Pi)? You can escape from their system and do this. If you don’t already have an iHost/NSPP/RP/PC it’s more expensive than just getting a motion sensor though.

The entire reason I have invested so heavily in Sonoff / ewelink devices - is so that I am not reliant on solutions like raspberry pi / home assistant / etc

Its also super frustrating that the solution to a small software issue is “why don’t you buy this very expensive thing”

I also already got myself the NS-Panel - and with how dissapointed I am in that device, I am not keen to spend the amount that the NS-Panel Pro costs

This should be an issue that can be resolved by exposing it in software, and I cannot imagine it would be difficult to add validation to the software to account for the cases where exposing this would cause a problem (or warn that using in both trigger and action may cause undesirable results - and allow us to accept the potential issues)


I had the same problem. Fixed it by defining an additional manual scene that triggers the device and invoke it in the action section of your scene. Clumsy, but it works.

1 Like

May I ask that you elaborate on your solution please? In may case I have an auto scene that is triggered by a device turning on. If I turn the device on using the button in the app or physically pressing the button on the device or via the schedule on the device then the auto scene works. If I operate the same device via a manual scene, then the device itself operates as expected, but the auto scene is not triggered.

My use case is controlling my ceiling fan (on an iFan controller) in my study…

I want to say:

if temp is above 23c
fan light is on
set fan to medium

but if I select the fan light on as part of the trigger criteria - then the fan dissapears from the action portion in the app…

vice versa - if I first populate the action, and set the fan level to meduim, and then return to the trigger, and look for the light - on the fan controller… again - the fan controller is not there.

  1. create a tap to run scene that turns on the fan to medium
  2. create an automatic scene that runs if the temperature AND fan light is on that triggers the tap to run scene you created in 1.
    Alternatively you can do this using ‘Olisto’ probably, as long as you don’t mind a little bit of latency.

ok - but that is needlessly complicated… and it makes me create a scene to do what the devices standard function already is… and for controlling the fan - I would need 4 extra scenes… one for each speed, one for off…

multiply that by every fan I have in my house…

its a messy needlessly complicated answer to a very simple thing… thus the request to unlock this option…

if I have to have a hundred scenes for these things, administering my automation is a nightmare. and anything that interfaces with ewelink becomes flooded with nonsense…

please - enable this basic functionality. Expecting the end users do have messy solutions is really frustrating

1 Like