I have a problem with the temperature controlled device scene

If the temperature is 22, I am creating a scenario that opens and closes if it is 23, but it works very unstable and sometimes does not work. what could i be doing wrong

1 Like

What device?
Sensor connection OK?
WiFi connection OK?
Automatic scene?
Manual scene?

Zigbee bridge+ temp&humidity sensor(zigbee)+plug(zigbee)
Sensor connection is ok.
Wifi connection ok.
Scene is automatic.
scene sometimes works, sometimes it doesn’t.

2 Likes

Hello forum!

I have experienced the same instability issues with scenes that include temperature/ humidity sensor, but only because the scenes don t trigger when I select a specific time interval for them - for example I want to turn on the heating if temperature is lower than 22 degrees, but only in weekdays between 13:01 - 19:00. Even if the temperature is lower and the time interval is correct the scene does not trigger so I need to enter it and click save without modifying anything.

I see your pain. This is something also bugs me. I created another thread about this a few days ago. Erin (ewelink staff) said they are looking into it. I hope they will update how scenes trigger when entered said effective time period.

Still same problem :(.
Even Sonoff before promise decide this this days …
Only if switch off/on or save.
I understood Sonoff know about this problem.
May be they can make update about progress in this problem.
I have many devices an pro plan and do not want change supplier.

Also having problem with sonoff zigbee temp sensors. They are very unreliable. Have used them to control temperature to keep water from freezing in my cabin. They are so bad that you need to watch them manually every couple of hours. Now using sonoff th16. They are almost 100 percent reliable. Glad i didn’t have to speak my mind about sonoff zigbee motion sensors😂

evelink support contacted me about the problem and they have no fix for now. We will have to adapt or move to a different platform.

Is there a different platform for us to use these products?

it doesn’t sound right to write it here but I’m working on using raspberry pi and home assistant.
I wouldn’t do that if ewelink didn’t ignore this problem.

I have come to same conclusion. Right now i flash the TH with tasmota and go to home assistant, the ewelink platform is to unreliable fore now.

The issue is the effective period. Scenes don’t work reliably if the effective period is set. Therefore, I solved it by creating one scene without any effective period, just switching on heating based on temperature (simply remove the effective period). Then you create two more scenes: one enables the first scene at the beginning of the effective period and the second scene disables the first one at the end of the effective period. This works well.
Another option is using a timer controlling the smart switch itself but there is a limit of 8 time values, I think.

I am sorry, the solution with 3 scenes is not reliable either. It worked a couple of days but stopped working yesterday. Moreover, there is no reply from ewelink staff and therefore the only solution I can see now is to use another ecosystem.

Has anybody tried Tuya or SmartLife? I am going to give it a try tomorrow.

i got my raspberry pi 3, installed home assistant and connected my ewelink account. i am now able to write “any” automation that i want and they all work awesome. Next i am planning to flash tasmota to zigbee bridge. sorry ewelink.

Pretty sure Home Assistant will do it. Sadly the microSD card on my Raspberry Pi 3B died and so I haven’t tested the Sonoff Dongle Plus I have. Pretty sure you can use the hub you already have with Home Assistant if you change the firmware on it. Was going to convert mine into an extender.

Bad luck. I was not able to add my Sonoff ZigBee Bridge to Tuya nor SmartLife. I will need to stay with ewelink until there is a fix.