Struggling with eweLink

We have two premises, home and office. Both are heated with IR panels. This year we converted all to be controlled with Sonoff smart switches. All works well apart from the automated “Scene” controls. I have an external temperature sensor and I wish to use different panel conmbinations dependant on the external temperature, e.g. “If below 0C use this combination”, “if between 0 and 5c use this” and “if between 5 and 12 use this”. There is also a time of day control, and an internal temperature control. The controls are linked with an “And” (All conditions are met). If I remove the external temperature control, it all works, but using this control it does not work.

OK, have got to the bottom of it. The “Effective Period” control just does not work. This is a shame as without it one needs two scenes to control a function, one to switch on and one to switch off. Hopefully it will be fixed soon.

Apparently both conditions are not met.

Thanks Jam3, all conditions were met. I have now found the problem - The “Effective period” control in eWeLink just does not work.

As I can see, the effective period are two hours, between 06:00 and 08:00, right? It means that between 08:00 and (overnight) 06:00 this scene is inactive.

Yes, that is what I would like. But it is also inactive between 06:00 and 08:00

Is your time zone set rightly? I don’t think you’re dumb but sometimes we people overlook basic things :sunglasses:

:joy: :joy: I know, it caught me out back in the day when I first started using Sonoff, the system had defaulted to Shenzen. Yes time zone/location is right. The “Effective period” control just does not work, I have tested it extensively and it fails no matter what the configuration. Have you tried it? If you have it working let me know what your config is. It is a great shame as when this feature appeared in the web version of eweLink (not there yet on the app) I was very excited as it meant I could almost halve the number of scenes I was using (one to switch on, one to switch off) but now after a week or two of trying to establish the probelm, I have had to recreate all of the switching off scene’s. I may look around for othe IFTTT products.

What happens if you create your scene in the eWeLink app? Before testing, be sure to delete it in eWeLink Web.

Thanks for the reply, still the same. Most of them were created on the App and then modified when I started using the web version, when I became aware that the “effective period” was available in the web version.

Strange, indeed. I have no idea how to bypass this. If some thought strikes my mind, I will come back to you.

Thank you and for all your help. Last night I ran the following tests, similar to my earlier ones, but this time recorded the results systematically for you. In each case it was a simple scene switching the same single sonoff switch, the only things that changed were the method of setting the time of the trigger -

  1. Created scene using App. - Worked fine.

  2. Opened the above scene in eWeLink Web to operate using “Effective period” - Did not trigger.

  3. Made new scene from within eWeLink web with “Effective period” - Did not trigger

  4. Modified above scene in eWeLink Web to be triggered by time - Worked fine.

Not sure that helps
Thanks again

I did a test and “Effective period” works normally for me. (eWeLink WEB)
If the conditions are met, the scene is active for the time period. After the selected time range, the scene is not executed.

However, it is important that the scene conditions actually change - if they are still the same, the scene is activated once at the beginning when saving, and then in order to work, they must change and return to the preferred ones.

But “Effective period” works fine for me…

Looks like a software error. Is there a reaction from eWeLink guys?

The “Effective period” does not act as a trigger, it only acts as a joint state determination when the IF configured for the scenario change to satisfied.

1 Like

Interesting. How can a cloud based service work for one person and not another? It almost suggests that my system setting could be playing a role in this. Which also seems highly unlikely

Hi Songal, thank you. Yes, I think I understand that. My assumption is that when you say “Effective period” this would be the period through which this scene would be effective, and the trigger and device to be triggered would be covered by the IFTTT statement only within that period, am I right in that assumption? So I have just run the attached test scene that, if I am correct in my understanding will switch on my presentation screen at 10:00 if the temperature at the sensor is less than or equal to 18C. Is that right?
It didn’t switch the screen on nor did it email me. So what do I have wrong with this scene for it not to work?

Thank you all.

And just for clarity, this is the temperature sensor

I speculate that it may be your IF settings.
As @songal mentioned, the time period is an indicator of activity but not a trigger.

My test is based on two smart devices and a time period.
In the set time interval, the scene responds to IF, in my case it is a change of the smart socket state to OFF and then THEN is executed.

In your case, I speculate that for some reason the IF may not be working properly and despite the correctly functioning time, the trigger does not work properly.

It looks like some kind of error in observing the variable for the trigger… I would do a test and force a temperature change so that the sensor records the actual temperature movement. Because theoretically it may be that the temperature is so constant that the trigger does not respond.


It does not have to be immediate 10:00 if the conditions are not met. But if the conditions are met between 10:00 - 10:59 the scene should execute. After the set time interval, the scene will be inactive even if the variables are met.

I’m not entirely sure about these 18, theoretically it may also be below 18, i.e. the reaction at 17. The question is how the ewelink team implemented it.

Hi Morgan, thank you, yes I agree with all you say. Can you see anything wrong with my IF statement? To me it looks fine, and I have tried numerous scenario’s. If I change the timing to be an IF rather than effective period it works, if I use effective period it doesn’t.