Sonoff Powr316 online but not responding

Hi, I have a Sonoff Powr316 which powers a 2000W panel heater. This morning the device is powered on, as the network LED is ON, but the switch is off (not powering the heater). On the app it is shown as the switch is ON, but if I click it says “Failed. Please try again”. Nothing happens when I click the physical button on the device.
Please note that the device is online and responsive as I can turn the network LED ON and OFF from the app. Anyone has any idea?
Thanks in advance

Can’t L-Out be turned on manually or via the app? Maybe the relay is damaged…
Reset to factory settings and set again…

Do you have a voltage meter? Check if there is anything at the L output.

I checked, there is nothing. Also, I have reset it to factory settings multiple times this morning.
I have it on Home Assistant and I have an automation that turns it on at 7AM, but I can see that it is stuck on On since 6:18AM, so not sure how it would have damaged. I only used it since last Friday

It’s hard to give advice in such a situation.

But if after a factory reset doesn’t respond to the physical button to connect/disconnect the relay, something more serious has happened to him.

There’s probably not much that can be done here.

I understand that you tried a factory reset and the ewelink app first before connecting it to the automation?
If it does not respond positively to resets, to use it with an application, there is no new firmware available… Does it have firmware by sonoff, if you have another FW there, maybe flash again.

Disconnect all cables from it, do another hard reset, turn it on and connect the ewelink app. If still doesn’t respond to anything, I guess we won’t come up with anything here… :frowning:

Thanks Morgan!
Yes, I have done a factory reset while the integration to Home Assistant was disabled, and yes, it has the official firmware installed on the eWeLink app. I will try to disconnect all the cables and do a factory reset again. Thanks for your help

You can also check the voltage on the live wire L that goes into L-In. Maybe it’s not getting enough power from the mains or the Air Switch/Fuse is causing some anomalies, but I highly doubt there’s a problem with the inputs, either there would be electricity or there wouldn’t be any at all.

Ultimately, the only solution is to replace it if you have a warranty.

It’s hard to guess, something may have gone wrong inside the fuse/relay… I don’t know the device diagram, so it’s hard to guess.

I think the relay is burnt. These 16A are not real that much. For appliances larger than 1500W, use relays with at least 100% of the above. More precisely, if your load is 2000W, the relay must withstand at least 4000W and more. This applies to smart relays.

I am facing similar issues !
Seen online but not responding as you faced, and also seen offline and “all LEDs are off” !!!
I have to reset the fuse to bring it back to life.

Any idea on what’s wrong ? I have checked the cabling, all is good.
This issue happens sometimes (1/7 days maybe).
Can this be related to wifi coverage loss ?
I was expecting the wifi led blinking or something like that …at least some led on. I can not even start/stop manually from the button …it’s completely frozen