Sonoff and vpn

Hi all,

i have been using vpn on router for years with sonoff and ewelink. but since yesterday the devices no longer connect … or connects randomly. as soon as i deactivate the vpn it works again. have you blocked access to vpn ips?

I reset the router anyway, but I still have the problem.

Does anyone know the IPs of the ewelink servers so that I can try to unblock them through my VPN?

Thank you in advance for your answers.

Just curious, why are you enable VPN all the time?

I have similar issues. My router is OpenVPN (DDWRT) and sonoff are randomly disconnecting for minutes and come back. If Bypass VPN, everything is fine… Did you find any solution?

I am running a separate IoT VLAN, which bypasses my VPN configuration (router pfSense)

Alternatively you should be able to manually configure the VPN bypass for each Sonoff device on your router (assuming that you have fixed IP addresses assigned to them)

Here are several steps you need to explore:
-Ensure your Sonoff devices and router have the latest firmware versions installed. Outdated firmware can sometimes cause compatibility issues.
-Review any recent changes to your VPN configuration or settings that might have inadvertently affected local network access or device communication.
-Check your VPN provider i.e., Nord or PureVPN for any known issues or updates that might be related to device connectivity.
-check if your VPN uses its own DNS servers. if so, consider temporarily switching to your regular DNS servers or using split tunneling to exclude eWeLink traffic from the VPN.

  • In the last, if the above options do not work then power cycle your Sonoff devices, router, and VPN connection to Potential glitches.

Some VPN software provides logs on how it handles traffic from different requests, you can filter out what’s going on, and make customized rules for eWeLink devices.

Or just simply, add all eWeLink devices to a whitelist.