On iHost static IP again

Good morning,
I recently purchased an iHost device and sadly discovered it misses settings for the network configuration.
Since in our LAN all control devices have static IP (that is outside the DHCP server range), so I tried to assign a static IP to iHost as well but this is apparently not possible.
As last chance i tried to reserve a lease using device’s MAC address, but unfortunately it seems that device does not supply correctly its MAC, because in the leases table I see a 18 bytes hex code that has a fixed leading part that remain unchanged and the last part which changes every time the device is rebooted.
I’ve actually more than 80 devices on the lan and none of them behave like iHost.
I read that some users forced their routers to always assign the same IP, but i cannot do the same thing, since the DHCP service is manged by a Windows Server 2022 machine and as you can see in the picture below, the MAC address is not correctly reported and thus the lease reservation option does not work.
Is there a way to access iHost with ssh or telnet and change its configuration?
Thank you in advance for your help.

on the settings page of iHost, you can see its MAC address, try to assign static IP for this MAC address.

Thank you for your reply.
Unfortunately, as told in my previous post, this is not possible.
If I reserve an address based on the MAC i see on the setting page it’s simply ignored, because the server apparently does not receive it in the DHCP request, but the long digit sequence (18 bytes, I don’t know if it is some ClientId or other) shown in the picture above. Furthermore this string is not fixed, but the last 8 bytes changes every time iHost is rebooted and thus, even assigning a fixed IP with this string on server side doesn’t work.
Unfortunately the DHCP service is hosted on a Windows 2022 server, that is our corporate domain controller and for this reason i have to manage IP addresses only in this way.
However I’ll try to see if one of $10 access point I installed (which has the DHCP server capabilty) can correctly assign a static ip to iHost, putting all of them on a different VLAN, but this is obviously a temporary solution and is ridiculous that a $150 hub misses a function that is common even in very cheap devices.


Hello, I advise you to call a friend who understands Internet networks and settings! I see in the above picture that you are hiding the last digits of the internal IP which gives you the impression that you don’t know what you are doing.

Seems like a standard Windows DHCP server issue, where ClientID gets pulled instead of hardware MAC address.
I don’t have iHost, and I’m not familiar if ssh can be used on it, but if you can use ssh you should be able to fix it easily.
There are multiple reports with a similar issue (Windows Server + DHCP Server). Just google “strange MACs on Windows DHCP Server”.

Yes, I’ve already found a solution on internet, but unfortunately it requires a root access to the device.

Anyway thank you for your reply.

I blurred everything but the Unique ID of iHost and left the first two bytes of internal address visible only to let readers know what subnet class the device is connected to.
However, if you are so skilled, why didn’t you submit a solution instead of posting such a useless reply?

I don’t have an answer, I’m not an expert especially with iHost. I just advised you to call a friend because I saw that you are you hide the standard internal IP addresses of all routers. Read information about 192.168. and you will see that there is nothing to worry about if someone sees it.

as Undeene mentioned, this might be windows server issue, we did some test on some routers, the static IP both work well on iHost.

Yes, according with the informations found on internet it’s a Windows Server issue that unfortunately can’t be fixed on server side. A possible solution on client side is to force it to supply its MAC address instead of Client ID by inserting “send dhcp-client-identifier = hardware” in /etc/dhcp/dhclient.conf (assuming that iHost is Linux based) or at least this is what I found as fix for similar issues.
If you have the possibilty to test the above command or tell me how to modify the dhclient.conf file on iHost I’ll be glad to make some test and share the results with the community.

Thank you for your support.