iHost has a different IP address after every shutdown/restart

iHost has a different IP address after every shutdown/restart.
I use a MikroTik as a router, DHCP mode is on and I automatically change the address for each added device to a static one, including a comment for clarity.
With iHost, the assignment does not want to work and the addresses “multiply”, they never end up at the same IP.
With all other devices, including Sonoff, it is without problems. What am I doing wrong ?

I deleted the “Device ID” of the iHost in DHCP leases and left only the MAC address.
For the first time since switching on, iHost kept the static IP assigned to it. I will see how it behaves further.

static IP settings may vary from routers, since we don’t have a MicroTik router, here’s the process about MicroTik I found on Google:

  1. Connect the device to your network and get an IP from DHCP as usual.
  2. Go into the Mikrotik’s IP > DHCP-Server menu and click on the leases display.
  3. Scroll through the leases and find your laptop’s lease and double-click it
  4. In the window that opens, there is a button on the right hand side “make static”
  5. Click that button and you’re done.

Did you set static IP in this way?

Thanks for the response, I’ve been doing it that way for years. I have more than 100 devices (most are from Sonoff) at home that work this way, iHost is the first device that did not allow this.
We’ll see if it was the ID or not. It works so far, tested on several restarts.
MikroTik was perhaps bothered by the “long” iHost ID :slight_smile: