NS Panel Pro Thermostat problems

I used to have the simple NS panel with an SNZB-02 thru hub and in auto mode with sceduled time frames was working as it should.

I moved to NS panel Pro with the same SNZB-02. After a day I could not make it work.
In Auto mode, acts unpredictably. Many times leave the action device ON after reaching the target temp, even if the HEAT icon goes off.
In any setting change, schedule times and days reset to ‘‘everyday’’.

Manual mode looks also unriliable but I didn’t test it a lot.

Anyone knows about the issues?


For anyone with same case, I just realise that even the Heat icon is off, thermostat wait for the given threshold, to turn off the astion device.
Can someone confirm this?

I think would be better to keep the Heat Icon ON as long as action is ON

1 Like

Confirm! The same here.
Sometimes when use manual and then switch back to automatic (much lower temperature) it doesn’t stop heating. I have to turn the manual lower, and then switch to automatic again. After that, works OK.

1 Like

+1 If the thermostate set DISABLED, the action device is still running.

1 Like

Hi @bukovszki.zoltan @str858

Could you please submit logs both from the eWeLink app and NSPanel Pro, and DM me your eWeLink account?

Our dev team can further investigate the issue with these logs.


Just now thermostat reach the target temp. Heat icon apeared but action didn’t triggered. switch to manual and auto, works.
As I undertstand the problem is that Icon apears in exact target temp but action wait for threshold. (just my opinion).

*please give me some time to find the way to exact the logs since I recently dig to all these… (own about 40 sonoff devices though)

1 Like

Just last night.
Auto mode
target temp set to 19.5
temp accuracy set to 1
Sensor temp goes to 18.3

no action triggered
switch to manual and auto again
action triggered


Hi, I’ve the same issue.NS panel pro Controlling temperature with a SNZB temp, action with a zigbee relè. Thermostat created, heat turns on, once temperature is reached the icon goes off but the relè still remains on! I’ve modified the wall enclosure to install the NS PANEL PRO!!
8th of march and still no response?

It stays ON as it is in threshold limit. It will turned off when idle period passed.
at least, as I understand.

However thermostat in NSpanel pro stays unstable.
simple NSpanel works much better as a thermostat
at least, as I understandt.

I am now with multi thermostats on Home Assistant platform

Truth is that NSpanels are looking attractive and good to buy but I think they are still solutions that looking for the problem.
at least, as I understand, especially in Home Assistant network

1 Like

Good morning, I also have the same problem, for a while everything worked fine then, it does not turn the boiler on or off.
Is there any way that with updates, it will get back to working?

Seems to be a useless thermostat with leaving the target device open. Must be brainless programming…

Useless device…

Despite reporting simple bugs, the support team’s response is improper.

the thermostat is a simple application, and still in FW v3.0.0 the same issues are there,
-the action device sometimes is kept latched even if the setpoint is reached.
-the flame indication does not match the status of the action device!
-sometimes, and even if the thermostat function is disabled, the action device turns on on its own, and keeps on turning on every time we try to turn it off, and when I check the logs, I find out that the “scene” was turning it on!!

they keep adding useless features and the core simple features full of bugs.

Same issues here, thermostat is really unstable and unpredictable. Better look for an alternative solution like HA …