iHost - Alexa is sending the same message more than once

I’m using the “alexa - home” node provided by node-red-contrib-alexa-home-skill and node-red-contrib-ewelink-cube modules. Everything seems to be working, except for the fact that after the voice command, the message is sent more than once.

In the following example, the voice command was triggered only once.

During this processing, Alexa says, “Having trouble understanding right now”.

just tried, I created a flow like yours, one voice command with one debug output, see attached screenshot:

from your screeshot, seems like your alexa node ‘Corredor’ sent multiple command, as there were multiple ‘debug3’ in the debug results, It’s not like the ewelink node is the problem, because debug3 doesn’t pass the ewelink node

what about deleting the flow and try again?

1 Like

You were right Teki, I removed the device in the Node-RED Alexa Home Skill Bridge and it worked.

Thank you very much for your attention and support in this case.

This topic was automatically closed 12 hours after the last reply. New replies are no longer allowed.