Firmware 1.5.5 for Sonoff iHost is available to install

Nope. Then it doesn’t find the card.
"No TF card inserted (TF card needs to be inserted to use Docker function.)"

Interesting! I have two iHosts.
One (64GB card)updated smoothly. I was able to seamlessly access my installed Dockers.
The other one (128GB card) is disatrous. The card is not recognized and cannot be formatted. Tried to reformat it in Windows. Didn’t work either. This underlines the need for a backup. If future updates render the card useless, it causes major data loss.

@mezeibela63 what’s the brand and model of your card please?

It’s a Sundisk ultra 32Gb Class 10, in attachment is a picture of it.

Funny: Before 1.5.5 my 128GB SanDisk Ultra didn’t work. I had to get a 128GB SanDisk Extreme. With 1.5.5 the iHost won’t format the 128GB SanDisk Extreme, but now the 128GB SanDisk Ultra works.

Thanks for the try out and let us know, the team is coding and testing the V1.6.0 aimed to solve known issues about TF card which planned to roll out later tomorrow, hope you’d like to upgrade and let us know how’s going like always.

The compatibility of the TF card is really a tough one.

That’s why iHost should have a M.2 SSD module in it or so.
And why not use the USB port for storage? The USB port is now unused and that’s a pitty… :slightly_frowning_face:

After several tests I support @morne 's advice: This version does not bring new features. If you had major problems before, feel free and try if 1.5.5 solves those problems. Otherwise I recommend that you wait for 1.6 which will follow in a few days.

V1.6.0 was rolled out, 【Update】What's new in eWeLink CUBE V1.6.0

Please update it, have a try and let us know how it’s going, thank you guys for all your patience, understanding and collaboration wirh us.

1 Like

Thank you, @yitie - I’ll try it out immediately.

I started the upgrade from 1.5.5 to 1.6.0 and the iHost is in that stage, the front led is blinking orange, for over two hours.
How much do I have to wait?
Can I interrupt the process with turning off and on, what bad could happen?

Were you successful?

Yes, @mezeibela63 - I already commented in the other thread

Update works, tf card is also ok now. New Lab option. So far, so good. No configuration options or shell access for docker containers though,

1 Like

I am happy for you, my iHost’s front led is just blinking orange for hours and hours after starting the upgrade. I dont’t now what to do!

Unplug the power and re-enable the power. Updating usually should take max 3 minutes or so after you click the button at the webinterface of the iHost. Ater that the light will blink yellow/greenish. Then the webinterface will become unavailable. After that the front light will blink all RGB colors. At last you will hear the startup sound and the front light will return to blue.

Thankyou all I was afraid to do that but is what worked.
Now the TF card is seen, the docker is OK, the addons are there.
So far so god!

1 Like

I updated it to 1.6.0, the card is read by the ihost now, so far so good.

nevertheless, the update wasn’t smooth, the ihost was blinking yellow light for a long time, I unplugged it, and powered it on again.

I have a Docker Container with an available update." New version detected"
iHost offers to minimize during the download. But nothing happens.
Nothing is ever downloaded or installed.

Oh It does, eventually. I would really appreciate some sort of status or progress indication. On basically anything in the iHost.

Up two posts from cliff are moved from other topic to here to sort the relevant ones for better visible.

Seems discourse doesn’t handle this ‘post move’ feature well as expected, at least add some quote sign or something to distinguish those moved in.

1 Like