DUALR3 offline always

I’ve also been using SONOFF DUALR3 for some time but only these devices go offline. I’ve noticed that when the internet connection drops and it can’t automatically reconnect. I need to reboot the device, that is, cut off the power, but I’m 50 kilometers from the site and that can’t be done in a day or two. I tried rebooting the router but it just won’t connect. Please write how to deal with this problem. 5 of the devices are offline and it is not appropriate to make the owners turn off their electricity just to have the connection restored.

I have the same problem, i dont have more ideas to try,…

I restarted the whole house today, but one device fails to connect, and I have to turn off the power of the device only after the router has started normally. The problem is just too big. I had a device with version 1.4.0 I will not update it to see if the problem will be the same. Please the team pay attention to these devices!

Hi there, thank you for your feedback. Let me summarize the problem you have encountered - the device fails to reconnect after a temporary network outage or router reboot, is that correct? And this issue mainly occurs on devices running firmware version 1.4.0?

I also have the same complaint.
All my Dual R3 have 1.5.0 version and sometimes one of them, randomly, comes offline and only back to link after being rebooted.
Mainly happens with Dual R3 but have already happened with S26R2 and MiniR2, but, only Dual R3 is a matter for me because sometime is a weekly matter…
Thanks for you help.

I have 6 units that are 1.5.0 and one 1.4.0, all 6 units go offline when the internet goes down for some reason and won’t connect anymore until I turn it off and on again from the mains. The router does not need to be restarted. I still can’t tell if the problem is there with 1.4.0 because it didn’t interrupt the internet.
Addendum: I forced myself to install an additional BASICR2 device to reboot the whole house along with the router and all the other devices.

Today 14.10.23 offline and the device with version 1.4.0
Worst of all, I bought a whole house reset technique and again they won’t connect. I learned that for it to connect I only need to reboot the device, without the router, but there is no way to do that! Very please tell will this fix or is the problem hardware and should I remove all these devices?

I have the same problem with 3 Dual R3, they can take hours or days to disconnect but they always do, they never come back online until the power is turned off.

I am doing tests with my TpLink Deco X50 to see if anything improves, this problem is new, I hope they update the firmware and correct it.

It also happens to me that on iHost, they appear offline when they are online, but that is a different problem.

1 Like

Hi there, as far as I know, the devices are designed to automatically reconnect to the network when the internet is restored. If they do not reconnect on their own, it may be due to weak network signals at the time of reconnection or potentially influenced by the device’s firmware.

@Daniel_Zhan Hi Daniel, Could the SONOFF team check on this issue? We have received multiple reports from our users regarding connectivity problems with DUAL R3 devices.

The problem will not be a weak signal because it is close to the router and when connected the devices show a full signal.

Have the exact same problem. I have over 15 Sonoff distributed throughout my home, and 3 DUAL R3 devices. Whenever the internet drops out, all devices come back online when internet is restored except for the DUAL R3 devices. They remain offline until power cycled.

Clearly a number of people are having the same issue - Sonoff team should really start providing feedback here.

Does anyone know when there will be an update for these devices?
Edit: Thanks I got an update on one of my devices. Hopefully the problem is fixed and I will get it on the other devices soon.

I got the 1.5.2 update on all devices and the problem is fixed! Thank you!

I have the same issue even with the version 1.5.2.
(Dual R-3 stays offline until power cycle through the circuit breaker)
There should be a way to soft reset by turning it on and off a certain number of times.

I have also the same problem with all my shutters which are driven by R3’s. Before I used trust units but replaced al 9 with R3’s. Now I can pull my hair out I changed them for sonoff. I thought that it had something to do with my access points and it drive me crazy. Spend money on new access points , tried to reserve IP nothing helps. And it is only the R3’s . Only power cycle helps. I hope for a solution soon.

I had the same problem, but after they released version 1.5.2, everything went back to normal.

I have 1.5.2 across all the devices. This still go offline.

Please, help me with this!

I have 2 SONOFF DUALR3 that are updated to 1.5.2 and physically next to each other, every 10 days or so one goes offline.
Sometimes is one sometimes is the other, only way to restore things is to press the coupling button and sometimes I have to do the procedure many times because it gets stuck

These devices are completely unreliable. It’s time to push the stop loss button and go switch to shelly.

1 Like

@Daniel_Zhan any updates?