DUAL R3 and R5

That’s why I had the question if I needed a Remote Gateway.
Can you please clarify @StephenJ ?

I just confirmed and the Dual R3 has the latest firmware (V.1.5.0) and eWeLink version is above V4.28.

To add remote sub-devices to the Dual R3 in the eWeLink App, follow these steps:

  1. Open the eWeLink App.
  2. Go to the control page of the DUAL R3.
  3. Enter the Device Settings page.
  4. Look for “eWeLink-Remote sub-devices”.
  5. Select “Add” to add remote sub-devices.
1 Like

Does not work.
Dual R3 firmware v 1.5.0, eWeLink App v 4.32.1, R5 or S-mate. They don’t connect.

1 Like

It doesn’t work…
I get timed out when trying to add the R5 to any of the Dual R3 that I have.

@andrey2 Did you managed to add it using any other instructions?

@ruibritosantos No.
I only have one Dual R3, but 2 S-mate and 4 R5, none of them could add to Dual R3


Hello everyone, I have also problem with connecting R5 and DUALR3. Everything is up-to-date. Any solutions here?

One more issue report from my side.
Tried two different R5s with five different DualR3 Lite and one Dual R3.
No success to add any of these two R5s as a sub device to any of these six remote gateways.

All updated firmwares to 1.5.0 and ewelink app to v4.34.1.

1 Like

It doesn’t work.
Nobody on this forum was able to pair an R5 to a Dual R3, so maybe it’s time for Sonoff to start looking for bugs in the software/firmware…

Enrico.mcc I agree with you!

@StephenJ Let’s check with the SONOFF team to figure it out.


We have asked one of our users to send us the device back so we can reproduce the issue and fix it.
Please be patient and I believe the root cause will be addressed soon.


Daniej_Zhan great news, thank you, we will wait!

1 Like

We received the devices from users who report the eWeLink remote paring failure for DUALR3 and R5. We’ve tested them several times and no failure occurs. The DUALR3 can learn the eWeLink remote of R5.

So please follow the below instructions to pair the eWeLink remote.

  1. DUALR3 and R5/S-Mate need to be closed enough.
  2. Please long press the R5/S-Mate button until the end of the pairing process.

Hi Daniel. I have tested them several times few months ago. For me the R5 connected to the DUAL R3 but disappeared from the sub-devices menu after a few hours / days. Of course all scenes stopped working.
R5 was very close to the DUAL R3, like 0.5m. Tried with two R5.
I will wait for iHost to support eWeLink remote as that will make this local as well and avoid the bounce to the cloud

I tried again according to these instructions (bring the two devices very close together with the mobile phone), but nothing, still the same problem.

As far as I can see, more and more people are contacting this part of the forum as well:

So the problem still exists for me (and obvious, many other people).


Has it happened to someone also that the DUAL R3 is Offline?

I have 2 DUAL R3 and in addition to the situation I reported here of not being able to pair with the R5, they have been offline several times, having to disconnect from the electrical current and reconnect.

I have to buy 3 more if they don’t solve bugs I’m afraid.

Many thanks.


Today I just received email from Sonoff - they wrote me that problem is solved.

I tried now to connect R5 with DualR3 and everything works great now!



I´m very happy!!!

Is done team ewelink has solved the problem.

Is working already.

Many thanks for help.