R5W and miniR4

i bought R5W switch and miniR4
And trying to connect it
According to guide i need just to click any button while ewelink gateway is searching device
i have s-mate and it’s connecting as well but i can’t connect R5
İs there any reset button or other ways to connect? :frowning:

You won’t connect M5 to MINIR4. The M5 is not a remote (button). You may want to observe R5 from Sonoff. It will connect to your MINIR4 as well as to M5.

Oops sorry I’ve made a mistake:(
i wrote about R5W not about M5
i can not connect R5W

When you press any of the buttons, does the red light come on?

Yes, i will upload picture

For me it was easy to add s-mate, and i thought that to add R5 will be easy too
May be there is some reset buttons inside ?

No, there isn’t.

I understand that you don’t have another device with an eWeLink Remote to try to connect the problematic R5 and see if it works properly. Perhaps your R5 is faulty.

I used to have a similar problem with the S-Mate, but I no longer remember how I solved it. Patience is certainly recommended :slight_smile:

1 Like

In the eWeLink application, enter the MiniR4 settings.
Select ewelink-remote slave device.
Press add.
The device will enter pairing mode.
Press any R5 button twice.
The remote control should be paired with the minir4 gateway.
You set the functions of the remote control keys in the eWeLink application as SCENES.

Unfortunately i didn’t not have another devices what can work as ewelink gateway:(
İ see, thank you for response

Hello, i tried right now double click, but nothing :frowning: it’s not detecting

Try resetting the MINIR4 and connecting it to the eWeLink app all over again. Then try pairing R5 again.
Is your MINIR4 placed freely or inside, for example, a light fixture?

Hello, and thank you for trying to help :heart_eyes:

Finally i did it

  1. i had reset mini r4
    But nothing, then i put in 1cm between devices and after 2-3 tries it finally found the device, and after pairing i can usue it

Good! :grin:

1 Like