Devices suddenly going off-line for no apparent reason

I have around 45 eWelink devices, these all work on a second wifi mesh system in my home. For weeks they will work flawlessly. But, like just now, more than half will suddenly start showing they are off line. Then over several hours they will individually slowly reconnect. There is nothing I can see wrong with the wifi, because the Google-Hubs etc continue to work.
Has anyone else experienced this, it’s so frustrating.

1 Like

Hi John.
Yes, all my devices (18) went offline this morning just before 5 except my ihost. But on my ihost all its devices are also offline so i cant do anything with ihost either. My ihost shows its online but i can use it. I must be doing something wrong or this is all BS.

Are you using Ubiquiti / Unifi for your wifi? if so this worked for me, if not there may be a similar approach in your network also.

I have been having this issue with MiniR4’s, MiniR4M’s and DualR3’s (I also have 5 x 4CHPROR3 interestingly these never go offline)

Anyway, I seem to have solved the issue (Touch wood) using the recommendations in this post, it seems a bit of a heavy approach but it does seem to stop the issues I had.

(tldr: create separate 2.4GHz only SSIDs for each access point in the home, to stop the sonoffs from roaming around all AP’s and seemingly getting lost) -

Eg for the kitchen AP I have setup a wifi network called Kitchen-IOT, this is only broadcast through the Kitchen AP and I have connected all IOT devices in the kitchen to that SSID.

I have TP Link Deco X20 Mesh system, 4 base stations dedicated only to IOT devices. I find it hit and miss, there are times that I feel turning off the abiliity to roam works and times that it doesn’t. Having the roaming off, definitely effects the time it takes for the devices going back on line. Having roaming on has off-line devices go back online quicker. Now I’m back to everything working, but I’m considering going over to wired Zigbee/Matter hubs and connecting to one or two central bases.

Yes the UNIFI kit I have has the ability (Apparently) to lock a device to an AP (Disable Roaming) but it didnt work for me, the IOT devices still ended up roaming and dropping off