Changing Network

Hi, I have recently upgraded my virgin network and have been required to get a new hub and can no longer use my previous TP Link router. None of my switches now work as their old network was on the TP Link. I have asked the Virgin Router to split the signal so I have both a 2g and 5g network again and renamed both the signal to suit the old router. However, the switches do not have SSID so this did not work. I then tried to follow the start-up process to find a new signal through the app and as per the instructions but the switches will no longer find a new signal and do not appear on the app. Do I need to reset the switches? I don’t see a way of doing this? Any ideas on how I can reconnect them? Thank you.

Set your TP Link as bridge and connect it on Virgin Router using the LAN Ports

1 Like

Hi, Thanks for the message. Unfortunately I have tried this and it did not work, the bridge would then be on the new network which is not connected to the switches. Ideally I need to find a way for the switches to reset or forget the old network which no longer exists so it will be able to search for the new 2g network which has been set up. Are you aware of any reset button or protocol? Thanks.

What hardware (switches) do you have? If they are Sonoff switches, just long-press the reset button (in some cases, that is just the switch, itself, but check the instructions for your hardware), and the switch resets to its factory default and goes into pairing mode.

Hi, thanks for getting in touch. I have the standard EWeLink switches (eWeLink 1/2/3 Gang WiFi Touch Switch Wall Light APP Control UK/EU Panel fr Alexa | eBay). They come with a small manual but there isn’t much detail. They were fairly easy to install the first time round as I just had to be in the network that I was pairing the switch to and hold down the button until the small light flashed. Now when I try and follow the same instructions it cant find the switch. If I hold the button down the switch still flashes but doesn’t appear to be attempting to pair in any way.

Have you deleted the switch from your existing list? The app may not be trying to pair because it already has that switch. I am trying to remember any pairing issues that I have had, and that seems like a logical step that I would try. :nerd_face:

When I upgraded to a Superhub5 from a 3B I managed this by just using exactly the same SSID Name and Password. The S3B allowed separate 2.4 and 5GHz whilst the S5 enforced mixing, so I was worried the Sonoff switches would not work but they s were fine. To save headache I would just give them exactly the new router exactly the same SSID name and password.

Hi, Yes this was one of the first things I tried however I deleted it while not being able to connect to it. So even though it has disappeared from my app chances are the switch still thinks it is connected. I am sure I read somewhere after doing this that this was the worst thing to do because I think you can change the network manually on the app when connected. However still no luck unfortunately lol any other suggestions are greatly appreciated? :slight_smile:

hmmmm I am not sure if the issue has maybe come from me having a TP-link router as my 3B was on modem mode. Not sure why the Hub5 wouldn’t work in modem mode, as this should have just been a straight swap-over. However classic Virgin has just ignored my complaint and enquiry for help, classic Virgin eh… Not to mention they had the audacity to call me earlier this week and try to up-sell me for a package that is currently nothing but issues! Unfortunately, we are still without power so if you have any other suggestions they would be greatly appreciated as I am also not heard anything back from the official EWeLink technical team.

I don’t use official modem mode but I’ve given up on Virgin and when there is a problem resetting the modem to factory seems to always do the trick and so have 3 sets of networks

  1. Virgin Factory Settings
  2. Internet of things (connected to Ethernet on Superhub 5)
  3. Guest network ( connected to Ethernet on Superhub 5)

Now when I need to reboot everything (but my phone) remains connected to the external router and the guest network remains [if you reset the Superhub 5 to factory settings the guest network disappears]. Now if it plays up I just spend 5 seconds resetting the Superhub and leave it.

The thing is only one thing can do the allocation of internal IP addresses using DHCP and in your case both your TP link and the Superhub would fight over DHCP so you’d need to tell the TP Link not to. You’ll end up with some pointless extra Superhub wifi networks but it should work with the old router as long as DHCP is turned off.

It’s a bit of a pain because there’s a couple of things I’d like to have fixed IP addresses but whenever I reset the Superhub 5 it forgets them. It’s worth it not to bother with their customer support though.

If I were you I’d just turn off allocating IP addresses on the TP link and then plug it in exactly as if you were doing modem mode. Lots less hassle and before fighting with customer support you can reset to factory settings. They seem to love blaming completely impossible changes. Normally they tell me it’s my choice of wifi band even though the Ethernet to my PC doesn’t work.

When you say that you reset your switches, did you just long-press the button, or did you pop off the faceplate and short the reset terminals? I believe from the link that you provided that you have the version of the smart switches that has a factory reset option, but you have to use a bit of wire to short two contacts under the faceplate. That restores them to out-of-the-box condition, from which you should be able to follow the usual pairing process.