WIFI won't connect with advanced settings (L3-5M-P)

I use an L3-5M-P and it connects to my WIFI network, but it cannot connect to the eWeLink servers. My WIFI is using a router ( that acts as the default gateway and a NUC ( that acts as the DHCP server and DNS server. To ensure that my DNS doesn’t cause any issues, I have set the DNS for this device to and

This is the actual DHCP response that is sent to the device (

10:34:14.463626 IP (tos 0x10, ttl 128, id 0, offset 0, flags [none], proto UDP (17), length 333) > [udp sum ok] BOOTP/DHCP, Reply, length 305, xid 0x177804d4, Flags [none] (0x0000)
	  Client-Ethernet-Address d0:27:02:f7:b5:66
	  Vendor-rfc1048 Extensions
	    Magic Cookie 0x63825363
	    DHCP-Message (53), length 1: ACK
	    Server-ID (54), length 4:
	    Lease-Time (51), length 4: 3386
	    Subnet-Mask (1), length 4:
	    Default-Gateway (3), length 4:
	    BR (28), length 4:
	    Domain-Name-Server (6), length 8:,
	    Domain-Name (15), length 19: "int.ramondeklein.nl"

I am able to ping the device, but it keeps flashing twice per second and is shown as “offline” in the eWeLink portal.

When I disable the DHCP server on and enable the DHCP server on my router, then it connects immediately. In that case the IP address, DNS server and default gateway are

There must be something wrong with how the L3-5M-P handles these DHCP settings (they work on all my other devices). I guess the L3-5M-P can’t deal with receiving an IP address from a DHCP server that is has a different IP then the default gateway.

Does anyone have a suggestion how to deal with this?

May I ask why you don’t use the build-in DHCP service of the router?

There may have connect issues via agency network or VPN.

I don’t use my router’s DHCP, because it can’t update my internal DNS. I have 50+ devices in my network and all devices handle this properly. It seems the L3-5M-P has a bug in the networking stack that prevents this from working…

Thanks for your kind feedback.

I have transferred your problem to our technical support team for further checking, it may take 1-3 days.
Whenever the solution is found, I’ll let you know.

Based on our findings, the problem appears to be related to firmware. It would be helpful if you could update the firmware with us so we can determine if it is the cause of the problem.
In the meantime, we are waiting for the new firmware installation kit to arrive from the manufacturer.
Thank you for your patience

I would be glad to update the firmware. Once it’s ready, please let me know where I can download it and how to install it. Thanks for your support. Highly appreciated…


We hope this message finds you well. We want to let you know that a firmware update for your device has been released, specifically to address the issue you’ve been experiencing. We apologize for the delay in getting this update to you and appreciate your patience while we worked on a solution.

To ensure that your device is running smoothly, we encourage you to update to the latest firmware as soon as possible. This will not only fix the problem you’ve been experiencing, but also provide other improvements and features to enhance your experience with our product.

Please open eWeLink app and enter device page(Device ID: 10017bdc0b) to upadate your device. If you have any questions or encounter any issues during the update process, please don’t hesitate to contact us for assistance.

After you’ve updated your firmware, please let us know if you’re still experiencing any issues. We’re committed to ensuring your satisfaction and will work with you to address any concerns you may have.

Thanks very much. I upgraded to 1000.2.1062 and it solved my issue.