TRVZB firmware issue


my thermostats got a firmware update last night ( 5 of them last night and the rest this morning). They updated from 1.1.1 to 1.1.4. Since then the wont turn on. Usually i have them connected to my home assistant but i tried it with the ewelink app directly and its still the same problem. I can turn them to manual or Auto but they dont turn from idle to heating. My bathroom is cooled down to 16°C right now, the thermostat is usually set to 22° and is still in idle. Even if i turn the heat up to 35° nothing happens.
Is this a known problem? Is there a way to fix that? Can I reset the thermostats somehow or downgrade to the old firmware?

Our team will follow your scenario to reproduce the issue. If we confirm that this is the case, we will fix it ASAP.

good to hear. Is there a way to revert back to 1.1.1 in the meantime? since I guess this will at least take a few days, no heating in the entire house not so good

1 Like

I have the same problem, but when I set the target temperature below the current temperature, the thermostat goes into heating mode and does not turn off again. If you set the target temperature above current, the thermostat goes into idle mode and no longer heats.

1 Like

Ok i found something out:
I tried to factory reset one of the thermostats and when it went back on, the temperature was set to 10°C and the thermostat immediatly went to heating. (the measured temperature in the room is 16°C right now). When i set the thermostat to a number above the current value its closing the valve. So there seems to be a bug ± bug. The thermostat is counting the temperature difference in the wrong direction. so by setting all my devices to heat up to 15°C in my house they should all turn on, but the warmer it gets and the farther away from 15°C its getting, they would heat even more.

please hurry up fixing this please.

Thank goodness eWeLink does not make software for cars or trains :person_gesturing_no:


Please try to adjust the opening degree and closing degree to 100% to see if the issue persists. We only add this feature for such a new update.

I don’t have any such items.
I use Home Assistant and Zigbee2Mqtt and Sonoff Dongle-p.

I dont have that option either.

I’m facing the same issue. Thanks God I only updated 1 of my 10 valves!

Is there a way to revert back to 1.1.1? I tried forcing the update locally but got an “invalid image” error.

Same problem with version 1.1.4 on 3 pcs.
The regulator is not regulating and is 100% on unless it is forced to off.

Please advise to revert to previous version.

I face the same problems and it sounds like both missing config values are set to 0%.
I already raised a ticket at ITEAD.

Encountering the same problem after updating from 1.1.1 to 1.1.4: the battery remains warm even when the thermostat is set to 14 degrees. I am using Home Assistant with Zigbee2Mqtt and a Sonoff Dongle-p

Hi! The same problem here. The valve now works backwards. When too cold (compared to the set value) in the room it shuts the valve and when too hot in the room it opens the valve. Intrestingly the off mode is works right still

please factory reset your TRV and see the problem is solved?


Factory Reset has worked for me. TVR now working the way it was with new FW, Thank you.

Thank you. Factory Reset made it work for me. The two % settings still not appear in z2m.

The Factory reset below is working.

1 Like

Is the new firmware version finally available or is there a temporary tactical silence to regroup?

I am keen to ensure my clients don’t have their heating environments messed up by the latest release and I am interested to know if v1.1.4 has been pulled as TRV’s I’ve looked at this week on v1.1.1 do not show as having an update available?