Timestamp in the SONOFF GK-200MP2 Camera

My timestamp in the SONOFF GK-200MP2 Camera is not syncronised with my local time.
How can I change it?

Thanks in advance

loops in @PeterGoGo

Hey there, would you please send me a screenshot to show the Model of your camera?
let’s dig deeper

Thank You @yitie

Hi @PeterGoGo

Here’s the screenshoot. The model of my camera is GK-200MP2-B and the firmware is up to date.


No problem, I think the timestamp is a fixed issue with new firmware, and our college @PeterGoGo will help you with troubleshooting.

1 Like

The firmware is up to date, so let’s see what he can do to help me to change it.
Once again, thanks a lot!!
Have a nice day!

Hey there, thanks for the info. Please follow the steps below to correct the timestamp.

① Power off the camera
Download the bin file, unzip it, and copy the unzipped bin file to the root directory of the Micro SD Card
③ Insert the Micro SD Card into the camera
④ Power on the camera. After that, it will automatically enter the upgrade state(The IR LED will always flash) and will be online again after the upgrade
If the timestamp still doesn’t display properly, please go to Device Settings page, tap More Settings > Sync time.

Important Notes:
*Do not power off the camera during the upgrade process
*If the upgrade fails, please format the Micro SD Card on the Device Settings page in the eWeLink App, and then repeat the above instructions. Please transfer the important files to the Micro SD card before formatting.

Please let me know if it helps:)

1 Like

@PeterGoGo You’re Great!!!
That was a perfect solution!!!
It worked!

Just one thing, after downloading the bin file, there is nothing to unzip because it only 1 file, but I understood all the process that is very well explained.

Have a great day

So glad to know it helps:) Actually you need to download free software to unzip the file.

1 Like

He meant the BIN file isn’t zipped. So there is no need to unzip anything. Unzipping doesn’t need to be included in the instruction.

1 Like

Gotcha, thanks for your explanation:)

1 Like

Hi, I just tried this and now the camera won’t turn back on?

Hi there, you meant after the upgrade, the camera doesn’t work? Could you provide more details of the issue you met? You can also submit a ticket in eWeLink App. That will help us locate the issue. Thank you

Hello! I tried this, but now the camera does not work. I can not reset with the buttom, and it not conect to the internet. What is the sollution? PLS help me! THX!