SONOFF iPlug S40TPB power-on-state ignored (always stays off)

Think I’m filing a bug-report here.

I can’t keep either of my 2 S40TPB plugs to retain a power-on state when I unplug them and plug them back in. Their state changes to off.

Firmware on the plugs is 1.1.0.

And I presume you’ve selected the “Power- on state” option in your APP to “ON” or “Last state”?

Yes. “ON” seems to act like “OFF”.

So, before you unplug your socket from the wall is your appliance on or off?

On. S40 is providing power to a device.

S40 on. Device receiving power. Unplug the S40 (with device plugged in) from AC. Wait 5 sec. Plug S40 back in. I regain connectivity with eWeLink app but it is now off. I can turn it on with the app, or by tapping the button on side of S40, but it always seems to default to OFF when plugged in.

Have you gone into the App , selected your device gone into settings - top right, scrolled down and chosen “last state”?

Selecting “Last state” in your case should be the appliance turning back on

Ok, I’ll check that. They’re at work so can’t try until Monday. (Do you have one of these on-hand at your end? Wondering if it is working for someone else.)

I have something very like it, not sure if it’s the same model as yours but they all work very similar. I’ll check tomorrow and I’ll get back to you.

My wife brought home one of the S40TPB and I’m trying all the Power-On state settings… On, Off, Last-State and the S40 always returns to OFF after getting unplugged from the wall, then plugged back in.

Also tried with switch OFF when unplugged. Remained off when plugged back in.

Think I’ve tried all possible combinations (“Power-On State” and state-when-unplugged) and can’t think of anything else to try at my end.

Someone at eWeLink please check an S40TPB.

Gordon, just to check, each time you alter the power state in your app are you also pressing “save” top right?

Just checked mine, works perfectly. So when appliance is on before power cut it turns back on when power is restored. All this happens when power state in app is set to “last state” and SAVED

Yes, I’m hitting SAVE. (Tried again just to be sure I wasn’t missing something obvious.) It seems to remember the setting (I kill the app and go back to device and check) even if it doesn’t act on it.

Model: S40
FW Name: SN-BL602-S40-01
Firmware: 1.1.0

Do you want me to try record a video of this?

Yeh, maybe that the best thing, might show problem in more detail!