Sonoff camera on Google nest hub

Hello all,

Today I bought a sonoff camera 360 with cloud service, subscribed.
After that I connected it to Google home hub, it was synchronised, and tried to see live the images from the camera.

Unfortunately I’ve got into problems because the only things that I get are idle mode or live without image (black screen). I’ve waited more than 10 minutes and nothing happened. You can see in the images below.

Any idea what’s going on and how I can fix it?
Thanks in advance!

Hi there, may I get your device ID? I streamed my camera on Google Nest Hub and it turned out working great. Is your WiFi network stable enough? By the way, is the camera showing online on your Google Home App?

Hello Peter. Sure here it is a63001f32f. Yes, there are no issues with it. I even restarted it, changed the WiFi to another one but seemed that nothing changed.
Camera is showing online in the Google app, I can use it with no problems from the ewelink app.
Let me know if other information is required.

By the way, could you check the FW Name in the device setting page on eWeLink App?

You can see in this picture

Also here you can see the sw version

It’s the version with cloud service. Also the plan is activated. :blush:

Hi there, our tech team found out that Google lost connection with us right after it streamed the live video. Please the following two ways:

  1. reboot your google nest hub and ask google to stream again.
  2. If the first step doesn’t work, please check if your nest hub is in lower version. If so, update it and ask google to stream again.
    Hope it helps:)

Hello Peter, indeed the camera streamed one time and than, dead!

I’ve rebooted the hub mile times, also reconnected the ewelink with Google. I’ve tried almost everything but nothing happened.

This are the versions of the hub:

Hope it helps

What I’ve noticed also is that now when I try streaming the camera, first time it shows me the camera being in idle mode, I have to press the live video button from the screen and than the black screen with the live indicator appears.
Is this a point of hint for you? Does the camera go into some kind of idle mode?


The new interactive won’t affect the streaming. In eWeLink, the live video is successfully sent to Google and it received, but it finally failed to stream live video to the nest hub. That’s why we think the issue occurs because of the smart speaker.
Would you mind sharing the camera to our staff’s eWeLink account? I’ll send you the account in PM. We would like to try if it can stream to our nest hub. If it works at our side, there might be some problem with your smart speaker.

Hello Peter. Sorry for writing you again.
Is there a problem with the Nspanel lately?
It’s current version is 1.4.0 and we had a electricity outage.

From than I tried to change its location, add a heating relay or add widgets but all of this fails when I try.

Can you please let me know. Or is there any way to factory reset?

Thank you!

Hi codrin, thanks for the feedback. Our tech team is aware of this issue and locating it. I’ll get back to you when there is any progress.

Hi Cordrin, we have resolved the problem and everything is back to normal. However, we are still investigating what caused this problem. If you experience any further issues, please try the following steps:

  1. Power off the device.
  2. Wait 1-2 minutes.
  3. Connect the device to power again and wait for the device to boot up and reconnect to the network.

If the issue persists, please contact us again and we will do our best to resolve the issue and provide you with more help as soon as possible. Thank you for your patience and understanding.