[Solved] NSPanel Pro unable to press update button

So I tried updating my NSPanel Pro to v3.0 firmware but ended with it not booting. So I did a system recovery by turning it on and off 5 times. This worked and now my panel is booted up again with the OS version of 1.3.3. However, I’m now unable to update to the latest firmware. This is because when you press the “Software update” button a dialog opens with a list of all the new features and improvements. However, this text is so long it has pushed the confirm button off the screen and I have found no way to scroll down to it. Does anyone know how to get the NSPanel Pro to update without needing to press the confirm button?


We have rolled out a fix from the server side, could u plz try again when available?

Thanks for your reply. There has been no change. I have even rebooted the panel to see if that would help. This is what I see when I click the “Software Update” button.


There might be caches of your downloaded package, which take some time to be cleared automatically.

Do you still have this issue now?

I have two NS PANEL PRO units, when the new firmware version where released some weeks ago, I tried to update them, but only one works, the other one just shows an screen showing the news about the version but become freezed.

Someone can help me to solve this?



Hey @cazares.avila0605

Plz try again when available, and let us know if it won’t for for you.

I have tried again but I still get the same wall of text shown in my images. I have tried rebooting the panel. I have also tried doing a system recovery. This might have stuffed up the server side fix, sorry.


Plz follow the steps to submit a clientside log:

Settings - About - Join User Experience Improvement Program

Let us know when you have hit that button.



The “Join User Experience Improvement Program” toggle was already enabled on my panel. I have disabled and re-enabled it just in case and hit the section a couple of times. It makes a sound but nothing happens.


1 Like


The cache should be cleared now. Would u plz try again?

Thx for your patience.

Thank you. I was able to update the Panel and have done it twice so it is now running on version 3.0. Thank you so much for your help.

You are welcome. Glad it worked!