Nspanel v1.3.1 stuck on upgrading in app

New NSpanel, ewelink offered update to 1.3.1
Panel working and control also working via app. However app is permanently showing upgrading. Is this normal?

I have the same issue.

I have the same issue: Upgrade from 1.3.0 to 1.3.1 never shows completed on the app.

Also noticed that if I dont disturb the upgrade process, I am getting the attached error in ewelink app on the next day (it could be 24 hrs after I click to Upgrade)

@jaysweb @youri.nijsten @makriscc
Hi there,
Please upgrade the NSPanel with the tool I attached. (additional video is also for your reference)
Video link
Download Tool
More info needs to be paid attention to:

  1. Make sure the desktop and your NSPanel are connected to the same WIFI/router/LAN.
  2. while the NSpanel shows a blue screen, the status of it may display as “offline” in the tool, it is normal behavior, please don’t worry.

Hello @StephenJ

Can you please attach the OTA Update tool also?
I could only find the video from your post.

Also kindly confirm if this was tested in EU and if in ewelink app the status shows as Completed after this process?

-Thanks!

Hi there,

Yes, it was tested in EU and it can work.
Using this tool, you can update NSPanel to the latest version.
Please download the tool HERE

1 Like

@StephenJ thank you for the tool, however I didn’t try it since the latest update 1.4.0 has worked for me now and Status showing Latest Version.

Thanks again.

Thank you for the tool, this works for me, it solved the “System Data Error” mesage from 1.2.1 to 1.4 version.

Support and Nspanel pro??