Nspanel v1.3.1 stuck on upgrading in app

Hello, today I managed to update to 1.4.0 via the update tool but the wigets and weather are still not displayed. I think the problem is not that the device was not up to date.

I have also problem with widgets. I can add any to my both NSPanel. Before with 1.2 firmware and now with 1.4 so it was not firmware problem…

After i try to add any widget i get info:

Failed. Please try again

I tryed to add widget device from Philips Hue and from Samsung SmartThings

I can’t change location for wheatder too.

2 Likes

Hi, I can’t get the upgrade to work. The display keeps saying "upgrading"even after several hours.
with a complete power disconnect i can get the nspanel online.

I ran the upgrade tool 4 times now. laptop is on the same wifi
run the tool but i don’t see anything hapening. The video i can not open.
Is there a new link maybe.

I open the App. Login, refresh, select the nspanel and klik start.
nspanel goes offline and stayes offline

@wirkuspawel.pomiary @kotis32 Hi there, unfortunately, once you enable ADB, your device’s warranty service and firmware OTA updates will be terminated, and this change cannot be reversed.

1 Like

Hi there, we have noticed that some NSPanel may experience a freeze during the firmware upgrade process. You can use this tool to upgrade the firmware, and refer to the video and tool download link below (updated to the latest version):
1. Video
2. Tool

More info needs to be paid attention to:

1. Make sure the desktop and your NSPanel are connected to the same WIFI/router/LAN.
2. while the NSpanel shows a blue screen, the status of it may display as “offline” in the tool, it is normal behavior, please don’t worry.

Yes I know.Unfortunately.I have already ordered another one.
Thanks

Hello, I already ran the application but it tells me that “login fail” do I need to have the paid ewelink application?

Hi, “login fail” for me too.


I think it´s because the area choice.

Hi, i have a Macbook, what program can I use because this one “update tool” doesn’t works, and my nspanel is showing “system error” and I tried all the things to solve the problem and I can’t.

Hi there, could you please send me a private message with your eWeLink account then I can help to check the area your account belongs to?

Hi there, could you please send me a private message with your eWeLink account then I can help to check the area your account belongs to?

Hi there,
Thank you for reaching out. I apologize for the inconvenience, but the update tool is designed to be used on Windows computers. If you have a Macbook, the tool may not be compatible. In this case, we recommend using a Windows computer to use it.

hello, I have an ordinary nspane not pro and once I uploaded tasmote on it without making a backup of the original system, please help me how to upload the original sonoff software to this panel? I have a tft file and a backup but I can’t upload it to enjoy the original program from sonoff ewelink again

Hi Stephen, how long does the update run using the linked tool? I have the US version of the NSpanel, currently version 1.2.1. The screen is black with System data ERROR! I’ve downloaded the tool and run using EU area. The app now shows current version 1.3.7 but still upgrading.

Hi there, I’m trying to understand the issue you’re experiencing. Based on my understanding, there are two points:

  1. The NSPanel was on version 1.2.1 and displayed a black screen with the “System data ERROR!” message.
  2. You’ve downloaded the tool and run it using the EU area, and now the eWeLink app shows the current version as 1.3.7. However, the NSPanel still shows that it’s upgrading.

I’m unclear where the “still upgrading” message appears. Could you please confirm if my understanding is correct? If possible, it would be helpful if you could provide a screenshot.

I bought a new NSPanel today and it was delivered with firmware 1.3.2

I’ve tried to update the firmware via the app but it got stuck on status “Upgrading”. Nothing helps to get it away. I’ve tried to reset or put it in recovery mode but that didn’t work either.

What to do? Any solution to update the system? All the files shared in this topic are gone and not available for download.

Hi there,

I have the same situation and can move forward

I’m stuck on version 1.3.7, barely updating it.
But now I am unable to upgrade. Whatever I do.
Please advise and direction, how did you manage to do it?

What appears in the console is the following and I wait for half an hour without any response on the panel.

This is what I see in the logs:
2024-02-11 03:16:37,618- ERROR: An exception of type AttributeError occurred in the run function, C:\Users\pvutk\AppData\Local\Temp_MEI74842\coolkit_long_connect_threading.pyc file. Arguments:
(“‘LongConnectThreading’ object has no attribute ‘self’”,) - coolkit_long_connect_threading.py,run,[line:116]
2024-02-11 10:58:07,424- ERROR: An exception of type ConnectionResetError occurred in the run function, C:\Users\pvutk\AppData\Local\Temp_MEI67602\api_v2_coolkit.pyc file. Arguments:
(10054, ‘An existing connection was forcibly closed by the remote host’, None, 10054, None) - api_v2_coolkit.py,run,[line:395]
2024-02-11 10:58:07,624- ERROR: An exception of type ConnectionError occurred in the inner function, C:\Users\pvutk\AppData\Local\Temp_MEI67602\api_v2_coolkit.pyc file. Arguments:
(MaxRetryError(“HTTPSConnectionPool(host=‘eu-apia.coolkit.cc’, port=443): Max retries exceeded with url: /v2/user/login (Caused by NewConnectionError(‘<urllib3.connection.HTTPSConnection object at 0x000001CEA04ED100) >: Failed to establish a new connection: [Errno 11001] getaddrinfo failed’))”),) - api_v2_coolkit.py,inner,[line:53]

In the console it sees this:
NSPanel-US
Starting server, listen at: 192.168.xx.xx:36101
{‘result’: True, ‘msg’: ‘’}
https://eu-otadl.coolkit.cc
send_params: {‘model’: ‘E32-MSW-NX’, ‘version’: ‘9.9.9’, ‘binList’: [{‘name’: ‘user1.bin’, ‘downloadUrl’: ‘https:// eu-otadl.coolkit.cc/ota/rom/1c904cfc9443c7d322bd53ebd5875e2dd95b1a46aabcf46db8e9d47956ad8e4a/user1.1024.new.2.bin’, ‘digest’: ‘1c904cfc9443c7d322bd53ebd5875e2dd95b1a46aabcf46db8e9d47956ad8e4a/user1.1024.new.2.bin’ 1a46aabcf46db8e9d47956ad8e4a’}, {‘name’: ‘user2.bin’, ‘downloadUrl’: ’ https://eu-otadl.coolkit.cc/ota/rom/1c904cfc9443c7d322bd53ebd5875e2dd95b1a46aabcf46db8e9d47956ad8e4a/user1.1024.new.2.bin’, ‘digest’: ‘1c904cfc9443c7d322bd53ebd5875e2dd95b1a46aabcf46db8e9d47956ad8e4a’ 5b1a46aabcf46db8e9d47956ad8e4a’}], ‘autoRestart’: 1}

Hi there, it would be great if you could submit a ticket via in-app “Help & Feedback”, our support team will provide you assistance.