NSPanel PRO wont find any device


I’m not sure is this correct place to ask help from other people, but i’m having trouble with pairing any devices for my NSpanel Pro. I bought this unit to control my zigbee bulbs and smart plugs in my home. For some reason, this machine does not find ANY of those bulbs or smart plugs.

I have a philips hue bridge with some bulbs and smart plugs. While trying to connect the hue-account to eWelink, it says that none of the products are supported. Bought then some other brand zigbee smart plugs (Nedis) and was planning to connect them directly to the panel. When trying to do the “Find a Device” from the NSpanel, it will just not find those plugs, they just never appear from the search (yes i did have the plugs and bulb on pairing mode!).

The Nedis smart plug did work with the philips hue bridge, so im sure they OK and not faulty either. Just for some reason the NSpanel pro wont find any device. Also tried to disconnect those hue bulbs and plugs from the bridge and tried to pair them directly to the NSpanel, but it just doesnt find them.

Am i missing something, do i need some kind of extra zigbee bridges to get them connected or something else? There are alot of discussion in the internet, but im having trouble of trying to understand the whole way how this should works, thanks alot!

Only thing i would like is to control either the Philips HUE units with the NSpanel or if thats not possible, then some bulbs and plugs directly from the NSPanel. What are my options?

It’s because not all bulbs, plugs and switches are equal. And yes, you’re missing a lot. Sorry!

Thanks Jam3 for your reply! How can i verify that a smart plug is compatible with NSpanel pro? I cant just randomly buy a bunch of different zigbee smart plugs and then hope some of them work, is there a way to identify which ones do work? I did not find any specific list about supported devices.

Do i need also some extra bridges or should this unit be able to connect directly to those (or any other?) bulbs and plugs?

It’s because Sonoff/eWeLink doesn’t maintain one. There is a list but it’s very much outdated. You need to ask other Sonoff’s fans, like on this forum.
If you want to stick to eWeLink ecosystem, there’s nothing you can do or buy extra. However, the device called iHost has add-ons that expand compatibility with Zigbee devices. There’s also Sonoff’s ZBBRIDGE-U that is supposed to support third party devices but I have no opinion. Maybe a good choice since it also supports Matter. You need to ask here or chat with Uncle Google or Aunt Bing to find out.
Bare in mind that eWeLink echo system is a proprietary one and it’s closed. Nothing close to open platforms with huge communities (Home Assistant).

Philips HUE is compatible as you can see here:

Curb your enthusiasm. Not all Hue are compatible.

True … I had one that was not supported.

I reported to them and it becomes fully compatible from one firmware release to another.

Since both support Matter, have you tried connecting it to NSPanel Pro locally via Matter?

Thanks to everyone for their replies!

Tried this ”matter” method also. First copied the code from Philips Hue app, then pasted it to eWelink and it said ”faulty code”… after a while trying it, discovered that had to change the code type from XXXX-XXX-XXXX to XXXXXXXXXXX (without any - characters) and then it accepts the code. Then eWelink tries to search for hue for a while and ends out without finding anything. Then it just sais that ”are you sure your device is in pairing mode”. How can i get a hue bridge to pairing mode? There is not any pairing procedures given for the hue bridge anywhere, exept the very first time you pair it with hue app.

What is my simpliest way to solve this? What if i buy some Sonoff smart plugs, will the connect directly to my device or is there any other smart plugs available that connect directly to my device?

Do i need still some extra zigbee bridges or how can i just get this machine work properly for the easiest way? Thanks!

Here’s a guide: https://help.ewelink.cc/hc/en-us/articles/33836672583449-How-to-Connect-Philips-Hue-Bridge-to-eWeLink

It could be a network/app failure. If you have that code, the device should already be in pairing mode. What phone/app version/NSPanel Pro version are you using?