Inching duration not working with gate switch

Hi, We looking for a 12-24v switch that will work with inching mode, so that the front gate on the street will stay open for several minutes (programmable) after the button is pushed physically or on the App. Both switches will only stay open for approximately 2 seconds which makes them unusable for me even after changing the inching mode several times to different durations. My guess is the App is unable to change the firmware on the Switch for some reason. My power supply is 18v but I have tested with 12v also. The switch is running the latest firmware as it upgraded when I initially added it to eWelink app. Thank you for any help.

Is there anything I can try with this switch or does anybody know a switch that definitely works, its very frustrating as I have tried 2 switches already and I have to get someone onsite to wire it up for me so its getting very expensive? :frowning:

I can successfully connect to the wifi switch with the APP, its connected to our LAN, can hear the switch open and close (App or press) and everything seems to be operating normally except for that the gate striker will not stay open.

Our setup should be simple we only have the power supply, gate switch on internal wall, gate striker. Here is how it is wired:

I have tested these 2 switches, inching mode has not worked on either:
Current switch being tested

Previously tested
Previously tested