iHost unable to access login page

Hi, I recently purchased iHost. Whatever I did I cannot access login page. Tried several softwares to find actual ip instead of ihost.local, unfortunately its not in my network.

Removed every physical connections remained only ihost, no luck. Even my router page doesn’t show anyting connected.

When the ihost powers up and ethernet connection estabilishes blue light is on everytime i try to connect.

Please if you know anything let me know. Maybe im missing something.

I lastly installed windows server. Distrubuted dhcp from server with only newly purchased router. Still no luck :disappointed:

same here

Hello
Any news about this problem?
I have the same here
Thanks :hand_with_index_finger_and_thumb_crossed:

Sorry. Tried every possible way. Ended up returning it. It was probably faulty. New one started right up.

When you get iHost to access the login page you type http://ihost.local no need to find out IP first it will shows in the setting page after you selecting time zone and setting a password