iHost can´t connect with alexa via Matter

Hello everyone,

In the last few days, I’ve been trying to add iHost to Alexa using the Matter Bridge functionality, but without success. The Alexa app gets stuck in a loop, either measuring to scan or entering the Matter code.

Has anyone else experienced the same problem?

Thank you.

Of course. Use search function. This topic has been discussed many times on this forum.

Is that a first pair or shared from existing platforms like Apple or Google?

If possible, could you please share a screen recording of the pairing process?

Thx in advance.

Alexa have the worst Matter experience as i tested, no matter initially pair device to Alexa or share Matter devices to it, long way to get to the pairing procedure and have a really failure rate.

1 Like

try to be closer to alexa hub during pairing process , and few hints if you are using android phone then force close alexa app , turn on airplane mode and wait few seconds then turn off airplane mode , then try to pair to alexa again , if this didn’t help then try again but this time reboot alexa hub first . if you got a lot of devices its normal pairing takes longer time , and answer the question of @ward is this new pairing or you share from controller to another ?

Not had a good couple of days – matter to alexa broke.

Rebooted/turned off and back on, both alexa and ihost – nothing changed.
As a last resort removed the matter bridge and tried to add it back again. Now all I get to do is cycle through the same couple of screens – have you got a number, put it in, have you got a number ……….

When I initially did this – a couple of months ago – it worked immediately, and has been fine (except some of the names and so on).

Is there a guide on just how to do this – I have searched and cannot find the thing I used last time. The description on the ihost page doesn’t make much sense to me “2 Scan the QR code or type in the numeric code by using the App from Matter-supported platforms after being enabled to add the iHost-managed devices (eWeLink Smart Bridge).”
Any thoughts/ideas?

I have struggled with connecting to Alexa many times. Nothing came out of it. In the end, I gave up. I now use Home Assistant and the Hue emulation trick. It has worked flawlessly since February, although it is an unofficial solution. In theory, Amazon can disable this capability at any time. For some reason, however, it does not. Overall, I am heavily disappointed with Alexa and not just because of the Matter integration. I have four devices. Today, I would not buy them ever again.

Its working well here

That integration was a nightmare. I forgot to limit entities, which ended up with hundards of unresponsive devices in Alexa. And thanks to Alexa, I have to clear them one by one, taking me days to get rid of them. :smiling_face_with_tear:

It’s working here and there but not everywhere.