How to factory reset iHost?

Hello all, I have issue with my iHost not able to connect to my LAN : red led keeps flashing, and no blue led even if connected to the LAN after a while…

Any advise ? How can I factory reset my iHost ?


  1. Double press the reset button to reset the password (select “Forgot Password” in iHost centre admin console to reset the password)
  2. Press for 10s to factory reset
1 Like

Thx for your reply Teki !
I tried the long press option, hearing a kind of noise after the 10s, but unfortunately, iHost still not able to connect to network, led keeps shining in red infitively. Tested my network cable, any ideas on network side taht could explain why the iHost cannot start ?

Did you try another network cable? You can also check whether it works on another router.

I had a similar issue where the red light kept flashing and never turned blue. However, the issue was with the Zigbee co-ordinator. I was able to connect to my LAN.

Are you able to login to the iHost page in your browser?

and not to forget POWER INTERFACE means not only to power it up but also too shut it down without brute force by pulling the plug.

I had asked for that and same issues … as others had too like the question which HA implentation should be used.

A lot of repeatingly asked questions and maybe a hint to add these tipps into the UI of ihost to find it more instantly like for example in that system menu if I remember right.

I had given up to use ihost after I had lost my HA configuration once and had no file control in that older release … therefore I am still hesitant to give it another try.

But time will tell about the progress.

Thx for all your replies. Will try on a different router and LAN, and see if I can log on iHost interface, even if the red light keeps blinking…
More to come later so…