Homeassistant and DUALR3

Hallo there!

I’m was able to install the ewelink addon, and I am able to control my curtains using the ewelink app. HOWEVER, I cannot sync the devices to lovelace, or control them altogether. One thing I noticed is that the devices are duplicate in the web interface in the homeassistant addon, but not in the app.

I have tried signing out and then back into the web interface, and it didn’t help. What am I missing? I can’t find logs for me to try to do some troubleshooting here, so I’m a bit lost.

See below that the phone app shows everything fine:

And this is what I see in home assistant after opening the ewelink smart home link:

I can control the devices using the app, so that tells me they are working, so my current working theory is that the problem is on the home assistant addon. Where can I look to understand what is wrong? What am I missing here?

I did many things, and I don’t know which of them made it work, I leave them here for future reference, in case anyone wants to pick up from where I gave up.

  1. uninstalled the eWeLink add-on
  2. installed the Sonoff LAN integration ( GitHub - AlexxIT/SonoffLAN: Control Sonoff Devices with eWeLink (original) firmware over LAN and/or Cloud from Home Assistant)
  3. Set my Wi-Fi to be in guest mode (so the devices can only see the internet and nothing local; at the time I thought maybe Home Assistant may be trying to set the devices up somehow)
  4. Using the androind ewelink app, I opened each of the devices, went into settings, chose Motor, then under Motor Settings I chose Dual Momentary Swich, and under the reverse option, I enabled the “Reverse App Control”. After saving a couple of times, I ran into a save button that did nothing. I waited for a minute or two, and then a pop-up told me that the motor needed calibration - a new popup that I had never seen so far. I calibrated (it opens and closes the curtains a couple of times)
  5. I can now see and control my devices on Home Assistant, and it reports accurately on closed and opened states, I can set a % to open (which in all honesty is a bit hit or miss, but still good enought), and of course, I can open and close the curtains.

Like I said, I did many things, and I don’t know which of them helped. I hope you are able to replicate some of this in the future, and that it helps you like it helped me. Good luck.

If this post can help you?

AND here is the supported devices list: